# CVE-2022-29822: Feathers - Improper parameter filtering in the Feathers js library, which may ultimately lead to SQL injection

> Attackers can exploit improper parameter filtering in the Feathers-Sequelize library to execute SQL injection attacks, potentially reading or modifying database contents.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Oct 2022
- **Updated:** 11 Mar 2025
- **Also known as:** GHSA-5hq7-j5wq-p227

## What is CVE-2022-29822?

CVE-2022-29822 is a critical SQL injection vulnerability in Feathers-Sequalize, published on 25 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Due to improper parameter filtering in the Feathers js library, which may ultimately lead to SQL injection

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2022-29822?

2 open source packages ship an affected version, including feathers-sequelize. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `feathers-sequelize` | npm | From 6.0.0 | 6.3.4 |
| `feathers-sequelize` | npm | From 6.0.0 | 6.3.4 |

Products: Feathersjs Feathers-Sequelize.

## How do I fix CVE-2022-29822?

Upgrade feathers-sequelize to 6.3.4 or later.

## Is CVE-2022-29822 being exploited?

There is no known exploitation of CVE-2022-29822 in the wild and no public exploit code.

## Other vulnerabilities in Feathers-Sequalize

- [CVE-2022-2422](https://insights.sbomify.com/CVE-2022-2422/): Feathers - SQL injection via attribute aliases (critical 10.0)
- [CVE-2022-29823](https://insights.sbomify.com/CVE-2022-29823/): Feathers - Query “__proto__” is converted to real prototype (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-29822 and fix it if it is affected.

What it is: CVE-2022-29822 is a critical SQL injection vulnerability in Feathers-Sequalize, published on 25 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-29822 in the wild and no public exploit code.

Affected packages and fixed versions:
- feathers-sequelize (npm): affected from 6.0.0; fixed in 6.3.4
- feathers-sequelize (npm): affected from 6.0.0; fixed in 6.3.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-29822/ (Markdown: https://insights.sbomify.com/CVE-2022-29822/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-29822
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-29822
- OSV: https://osv.dev/vulnerability/CVE-2022-29822

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-29822/
Summaries are generated and may contain mistakes; the official description above is the record.
