CVE-2022-29823 Feathers - Query “__proto__” is converted to real prototype
Critical 10.0
Published
Updated
Check this codebase for CVE-2022-29823 and fix it if it is affected.
What it is: CVE-2022-29823 is a critical vulnerability in Feathers-Sequalize, published on 25 Oct 2022.
Exploitation: There is no known exploitation of CVE-2022-29823 in the wild and no public exploit code.
Affected packages and fixed versions:
- feathers-sequelize (npm): affected from 6.0.0; fixed in 6.3.3
- feathers-sequelize (npm): affected from 6.0.0; fixed in 6.3.3
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2022-29823/ (Markdown: https://insights.sbomify.com/CVE-2022-29823/index.md)
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2022-29823?
CVE-2022-29823 is a critical vulnerability in Feathers-Sequalize, published on 25 Oct 2022.
Official description
Feather-Sequalize cleanQuery method uses insecure recursive logic to filter unsupported keys from the query object. This results in a Remote Code Execution (RCE) with privileges of application.
Weakness: CWE-1321
Which versions are affected by CVE-2022-29823?
2 open source packages ship an affected version, including feathers-sequelize. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
feathers-sequelize npm | From 6.0.0 | 6.3.3 |
feathers-sequelize npm | From 6.0.0 | 6.3.3 |
Products include Feathersjs Feathers-Sequelize.
How do I fix CVE-2022-29823?
Upgrade feathers-sequelize to 6.3.3 or later.
Is CVE-2022-29823 being exploited?
There is no known exploitation of CVE-2022-29823 in the wild and no public exploit code.
Other vulnerabilities in Feathers-Sequalize
Sources
Also known as GHSA-p5m3-27vh-52j4.