# CVE-2022-29823: Feathers - Query “__proto__” is converted to real prototype


- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 25 Oct 2022
- **Updated:** 11 Mar 2025
- **Also known as:** GHSA-p5m3-27vh-52j4

## What is CVE-2022-29823?

CVE-2022-29823 is a critical vulnerability in Feathers-Sequalize, published on 25 Oct 2022. 

### Official description

Feather-Sequalize cleanQuery method uses insecure recursive logic to filter unsupported keys from the query object. This results in a Remote Code Execution (RCE) with privileges of application.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2022-29823?

2 open source packages ship an affected version, including feathers-sequelize. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `feathers-sequelize` | npm | From 6.0.0 | 6.3.3 |
| `feathers-sequelize` | npm | From 6.0.0 | 6.3.3 |

Products: Feathersjs Feathers-Sequelize.

## How do I fix CVE-2022-29823?

Upgrade feathers-sequelize to 6.3.3 or later.

## Is CVE-2022-29823 being exploited?

There is no known exploitation of CVE-2022-29823 in the wild and no public exploit code.

## Other vulnerabilities in Feathers-Sequalize

- [CVE-2022-2422](https://insights.sbomify.com/CVE-2022-2422/): Feathers - SQL injection via attribute aliases (critical 10.0)
- [CVE-2022-29822](https://insights.sbomify.com/CVE-2022-29822/): Feathers - Improper parameter filtering in the Feathers js library, which may ultimately lead to SQL injection (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-29823 and fix it if it is affected.

What it is: CVE-2022-29823 is a critical vulnerability in Feathers-Sequalize, published on 25 Oct 2022. 
Exploitation: There is no known exploitation of CVE-2022-29823 in the wild and no public exploit code.

Affected packages and fixed versions:
- feathers-sequelize (npm): affected from 6.0.0; fixed in 6.3.3
- feathers-sequelize (npm): affected from 6.0.0; fixed in 6.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-29823/ (Markdown: https://insights.sbomify.com/CVE-2022-29823/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-29823
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-29823
- OSV: https://osv.dev/vulnerability/CVE-2022-29823

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-29823/
Summaries are generated and may contain mistakes; the official description above is the record.
