CVE-2022-29858 Unpublished, protected files can be published via shortcode
Attackers can publish protected images by modifying image short codes in website content, bypassing intended access controls.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-29858?
CVE-2022-29858 is a medium-severity missing authorization vulnerability in n/a, published on 28 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Silverstripe silverstripe/assets through 1.10 is vulnerable to improper access control that allows protected images to be published by changing an existing image short code on website content.
Weakness: CWE-287
Which versions are affected by CVE-2022-29858?
2 open source packages ship an affected version, including silverstripe/assets. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
silverstripe/assets Packagist | From 1.0.0 | 1.10.1 |
silverstripe/assets Packagist | From 1.0.0 | 1.10.1 |
Products include Silverstripe Assets.
How do I fix CVE-2022-29858?
Upgrade silverstripe/assets to 1.10.1 or later.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2022-29858 being exploited?
There is no known exploitation of CVE-2022-29858 in the wild and no public exploit code.
Sources
Also known as GHSA-v68g-62v9-39w5.