CVE-2022-2986 Moodle Cross-Site Request Forgery (CSRF)
Attackers can force users to enable or disable H5P libraries without consent due to missing CSRF tokens in Moodle.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-2986?
CVE-2022-2986 is a high-severity vulnerability in Moodle Moodle, published on 6 Oct 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Enabling and disabling installed H5P libraries did not include the necessary token to prevent a CSRF risk.
Weakness: CWE-352
Which versions are affected by CVE-2022-2986?
5 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.11 | 3.11.9 |
moodle/moodle Packagist | From 3.11 | 3.11.9 |
moodle/moodle Packagist | From 4.0 | 4.0.3 |
moodle/moodle Packagist | From 4.0 | 4.0.3 |
moodle Bitnami | From 3.11.0 | 3.11.9, 4.0.3 |
Products include Moodle Moodle.
How do I fix CVE-2022-2986?
Upgrade moodle/moodle to a fixed version for your release line: 3.11.9 or 4.0.3.
Is CVE-2022-2986 being exploited?
There is no known exploitation of CVE-2022-2986 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2022-2986, GHSA-xjr3-fwp9-9g96, UBUNTU-CVE-2022-2986.