{"answers":{"affected":"5 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-2986 in the wild and no public exploit code.","fix":"Upgrade moodle/moodle to a fixed version for your release line: 3.11.9 or 4.0.3.","what":"CVE-2022-2986 is a high-severity vulnerability in Moodle Moodle, published on 6 Oct 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-2986 and fix it if it is affected.\n\nWhat it is: CVE-2022-2986 is a high-severity vulnerability in Moodle Moodle, published on 6 Oct 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-2986 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected from 3.11; fixed in 3.11.9\n- moodle/moodle (Packagist): affected from 3.11; fixed in 3.11.9\n- moodle/moodle (Packagist): affected from 4.0; fixed in 4.0.3\n- moodle/moodle (Packagist): affected from 4.0; fixed in 4.0.3\n- moodle (Bitnami): affected from 3.11.0; fixed in 3.11.9, 4.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-2986/ (Markdown: https://insights.sbomify.com/CVE-2022-2986/index.md)","id":"CVE-2022-2986","markdown":"https://insights.sbomify.com/CVE-2022-2986/index.md","name":"CVE-2022-2986","record":{"aliases":["BIT-moodle-2022-2986","GHSA-xjr3-fwp9-9g96","UBUNTU-CVE-2022-2986"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Moodle LMS","requires_auth":"none","summary":"Attackers can force users to enable or disable H5P libraries without consent due to missing CSRF tokens in Moodle.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"fedora","cpe":[{"product":"moodle","vendor":"moodle"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"Enabling and disabling installed H5P libraries did not include the necessary token to prevent a CSRF risk.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Moodle Cross-Site Request Forgery (CSRF)","id":"CVE-2022-2986","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"moodle:moodle","products":["moodle:moodle"],"type":"csrf","year":"2022"},"n_packages":5,"n_references":2,"next":{"headline":"Ldap WP Login / Active Directory Integration \u003c 3.0.2 - Unauthenticated Settings Update to Auth Bypass","id":"CVE-2022-2987"},"packages":[{"ecosystem":"Bitnami","fixed":["3.11.9","4.0.3"],"introduced":["3.11.0","4.0.0"],"last_affected":[],"package":"moodle","purl":"pkg:bitnami/moodle","source":"BIT-moodle-2022-2986"},{"ecosystem":"Packagist","fixed":["3.11.9"],"introduced":["3.11"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-xjr3-fwp9-9g96"},{"ecosystem":"Packagist","fixed":["3.11.9"],"introduced":["3.11"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-xjr3-fwp9-9g96"},{"ecosystem":"Packagist","fixed":["4.0.3"],"introduced":["4.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-xjr3-fwp9-9g96"},{"ecosystem":"Packagist","fixed":["4.0.3"],"introduced":["4.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-xjr3-fwp9-9g96"}],"prev":{"headline":"Missing authorization in SC9863A/SC9832E/SC7731E/T610/T310/T606/T760/T610/T618/T606/T612/T616/T760/T770/T820/S8000","id":"CVE-2022-2985"},"products":["moodle"],"published":"2022-10-06","related":[{"cvss_score":10,"headline":"File upload in n/a","id":"CVE-2006-4935","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Moodle does not properly validate module instance id","id":"CVE-2006-4936","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Unknown \"front page vulnerability with Moodle servers\" for Moodle before 1.3.2 has unknown impact and attack vectors.","id":"CVE-2004-2233","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2004-2235","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2004-2236","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Unknown vulnerability in Moodle before 1.3.4 has unknown impact and attack vectors, related to \"strings in Moodle texts.\"","id":"CVE-2004-2237","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Multiple unknown vulnerabilities in Moodle before 1.5.1 have unknown impact and attack vectors.","id":"CVE-2005-2247","kev_date_added":null,"published":"2005-07-12"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Attackers can force users to enable or disable H5P libraries without consent due to missing CSRF tokens in Moodle.","url":"https://insights.sbomify.com/CVE-2022-2986/"}