# CVE-2022-2986: Moodle Cross-Site Request Forgery (CSRF)

> Attackers can force users to enable or disable H5P libraries without consent due to missing CSRF tokens in Moodle.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Oct 2022
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-moodle-2022-2986, GHSA-xjr3-fwp9-9g96, UBUNTU-CVE-2022-2986

## What is CVE-2022-2986?

CVE-2022-2986 is a high-severity vulnerability in Moodle Moodle, published on 6 Oct 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Enabling and disabling installed H5P libraries did not include the necessary token to prevent a CSRF risk.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2022-2986?

5 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | From 3.11 | 3.11.9 |
| `moodle/moodle` | Packagist | From 3.11 | 3.11.9 |
| `moodle/moodle` | Packagist | From 4.0 | 4.0.3 |
| `moodle/moodle` | Packagist | From 4.0 | 4.0.3 |
| `moodle` | Bitnami | From 3.11.0 | 3.11.9, 4.0.3 |

Products: Moodle Moodle.

## How do I fix CVE-2022-2986?

Upgrade moodle/moodle to a fixed version for your release line: 3.11.9 or 4.0.3.

## Is CVE-2022-2986 being exploited?

There is no known exploitation of CVE-2022-2986 in the wild and no public exploit code.

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-2986 and fix it if it is affected.

What it is: CVE-2022-2986 is a high-severity vulnerability in Moodle Moodle, published on 6 Oct 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-2986 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected from 3.11; fixed in 3.11.9
- moodle/moodle (Packagist): affected from 3.11; fixed in 3.11.9
- moodle/moodle (Packagist): affected from 4.0; fixed in 4.0.3
- moodle/moodle (Packagist): affected from 4.0; fixed in 4.0.3
- moodle (Bitnami): affected from 3.11.0; fixed in 3.11.9, 4.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-2986/ (Markdown: https://insights.sbomify.com/CVE-2022-2986/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-2986
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-2986
- OSV: https://osv.dev/vulnerability/CVE-2022-2986

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-2986/
Summaries are generated and may contain mistakes; the official description above is the record.
