# CVE-2022-2989: Podman's incorrect handling of the supplementary groups may lead to data disclosure, modification

> Incorrect supplementary group handling in Podman allows attackers with container access to disclose sensitive information or modify data.

- **Severity:** High 7.1 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Sep 2022
- **Updated:** 5 Jun 2025
- **Also known as:** AZL-10964, AZL-36976, DEBIAN-CVE-2022-2989, GHSA-4wjj-jwc9-2x96, MINI-mfpq-732q-x432, MINI-vvcp-v9mc-r83c, SUSE-SU-2022:3819-1, SUSE-SU-2022:3820-1, UBUNTU-CVE-2022-2989, USN-6295-1, openSUSE-SU-2024:12556-1

## What is CVE-2022-2989?

CVE-2022-2989 is a high-severity missing authorization vulnerability in Redhat Enterprise Linux, published on 13 Sep 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

An incorrect handling of the supplementary groups in the Podman container engine might lead to the sensitive information disclosure or possible data modification if an attacker has direct access to the affected container where supplementary groups are used to set access permissions and is able to execute a binary code in that container.

Weakness: CWE-863 (Incorrect Authorization), CWE-842 (Placement of User into Incorrect Group)

## Which versions are affected by CVE-2022-2989?

4 open source packages ship an affected version, including github.com/containers/podman/v3 and github.com/containers/podman/v4. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/containers/podman/v3` | Go | All versions | 3.0.1 |
| `github.com/containers/podman/v3` | Go | All versions | 3.0.1 |
| `github.com/containers/podman/v4` | Go | All versions | 4.2.0 |
| `github.com/containers/podman/v4` | Go | All versions | 4.2.0 |
| `podman` | SUSE:Enterprise Storage 7.1 | All versions | 3.4.7-150300.9.12.1 |
| `podman` | SUSE:Linux Enterprise Micro 5.1 | All versions | 3.4.7-150300.9.12.1 |
| `podman` | SUSE:Linux Enterprise Micro 5.2 | All versions | 3.4.7-150300.9.12.1 |
| `podman` | SUSE:Linux Enterprise Micro 5.3 | All versions | 3.4.7-150400.4.6.1 |
| `podman` | SUSE:Linux Enterprise Module for Containers 15 SP3 | All versions | 3.4.7-150300.9.12.1 |
| `podman` | SUSE:Linux Enterprise Module for Containers 15 SP4 | All versions | 3.4.7-150400.4.6.1 |
| `podman` | openSUSE:Leap 15.3 | All versions | 3.4.7-150300.9.12.1 |
| `podman` | openSUSE:Leap 15.4 | All versions | 3.4.7-150400.4.6.1 |
| `podman` | openSUSE:Leap Micro 5.2 | All versions | 3.4.7-150300.9.12.1 |
| `podman` | openSUSE:Tumbleweed | All versions | 4.3.1-1.1 |

Products: Podman Project Podman, Redhat Enterprise Linux, Redhat Openshift Container Platform.

## How do I fix CVE-2022-2989?

Upgrade github.com/containers/podman/v3 to 3.0.1 or later.

## Is CVE-2022-2989 being exploited?

There is no known exploitation of CVE-2022-2989 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Enterprise Linux

- [CVE-2026-57231](https://insights.sbomify.com/CVE-2026-57231/): Podman: Malformed Image can trick podman run into leaking host environment variables into the container (high 7.5)
- [CVE-2022-2738](https://insights.sbomify.com/CVE-2022-2738/): Use after free in podman (high 7.5)
- [CVE-2021-20188](https://insights.sbomify.com/CVE-2021-20188/): Improper Authorization in github.com/containers/libpod (high 7.0)
- [CVE-2023-0778](https://insights.sbomify.com/CVE-2023-0778/): Podman Time-of-check Time-of-use (TOCTOU) Race Condition (medium 6.8)
- [CVE-2019-25067](https://insights.sbomify.com/CVE-2019-25067/): Podman/Varlink API Privilege Escalation (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-2989 and fix it if it is affected.

What it is: CVE-2022-2989 is a high-severity missing authorization vulnerability in Redhat Enterprise Linux, published on 13 Sep 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-2989 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/containers/podman/v3 (Go): affected all versions; fixed in 3.0.1
- github.com/containers/podman/v3 (Go): affected all versions; fixed in 3.0.1
- github.com/containers/podman/v4 (Go): affected all versions; fixed in 4.2.0
- github.com/containers/podman/v4 (Go): affected all versions; fixed in 4.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-2989/ (Markdown: https://insights.sbomify.com/CVE-2022-2989/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-2989
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-2989
- OSV: https://osv.dev/vulnerability/CVE-2022-2989

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-2989/
Summaries are generated and may contain mistakes; the official description above is the record.
