# CVE-2022-29907: Cross-site scripting in n/a

> Cross-site scripting vulnerability in the Nimbus skin for MediaWiki allows attackers to inject malicious scripts via Advertise link messages.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Apr 2022
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-mediawiki-2022-29907, GHSA-wghv-q62f-f457

## What is CVE-2022-29907?

CVE-2022-29907 is a medium-severity cross-site scripting vulnerability in Mediawiki Mediawiki, published on 29 Apr 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The Nimbus skin for MediaWiki through 1.37.2 (before 6f9c8fb868345701d9544a54d9752515aace39df) allows XSS in Advertise link messages.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-29907?

1 open source package ship an affected version, including mediawiki. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki` | Bitnami | All versions | 1.37.3 |

Products: Mediawiki Mediawiki.

## How do I fix CVE-2022-29907?

Upgrade mediawiki to 1.37.3 or later.

## Is CVE-2022-29907 being exploited?

There is no known exploitation of CVE-2022-29907 in the wild and no public exploit code.

## Other vulnerabilities in Mediawiki Mediawiki

- [CVE-2023-37303](https://insights.sbomify.com/CVE-2023-37303/): Denial of service in n/a (critical 9.8)
- [CVE-2022-29904](https://insights.sbomify.com/CVE-2022-29904/): SQL injection in n/a (critical 9.8)
- [CVE-2022-29906](https://insights.sbomify.com/CVE-2022-29906/): Missing authorization in n/a (critical 9.8)
- [CVE-2022-28205](https://insights.sbomify.com/CVE-2022-28205/): Business logic in n/a (critical 9.8)
- [CVE-2022-28206](https://insights.sbomify.com/CVE-2022-28206/): Missing authorization in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-29907 and fix it if it is affected.

What it is: CVE-2022-29907 is a medium-severity cross-site scripting vulnerability in Mediawiki Mediawiki, published on 29 Apr 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-29907 in the wild and no public exploit code.

Affected packages and fixed versions:
- mediawiki (Bitnami): affected all versions; fixed in 1.37.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-29907/ (Markdown: https://insights.sbomify.com/CVE-2022-29907/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-29907
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-29907
- OSV: https://osv.dev/vulnerability/CVE-2022-29907

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-29907/
Summaries are generated and may contain mistakes; the official description above is the record.
