CVE-2022-2992 Code injection in GitLab
An authenticated user can achieve remote code execution via the Import from GitHub API endpoint in GitLab.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-2992?
CVE-2022-2992 is a critical code injection vulnerability in Gitlab Gitlab, published on 17 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A vulnerability in GitLab CE/EE affecting all versions from 11.10 prior to 15.1.6, 15.2 to 15.2.4, 15.3 to 15.3.2 allows an authenticated user to achieve remote code execution via the Import from GitHub API endpoint.
Weakness: CWE-74
Which versions are affected by CVE-2022-2992?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 11.10.0 | 15.1.6, 15.2.4, 15.3.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2022-2992?
Upgrade gitlab to a fixed version for your release line: 15.1.6, 15.2.4 or 15.3.2.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2022-2992 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-2992 exists.
Public exploit code: 1 Metasploit module and 2 proofs of concept on GitHub.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2022-2992, GHSA-m7f3-552r-pf23, UBUNTU-CVE-2022-2992.