# CVE-2022-2995: CRI-O incorrect handling of supplementary groups may lead to sensitive information disclosure

> Attackers with code execution in a CRI-O container can bypass supplementary group permissions to read or modify sensitive data.

- **Severity:** High 7.1 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Sep 2022
- **Updated:** 29 May 2025
- **Also known as:** AZL-39882, GHSA-phjr-8j92-w5v7, GO-2022-1014, OESA-2024-1251, RHSA-2023:3216

## What is CVE-2022-2995?

CVE-2022-2995 is a high-severity missing authorization vulnerability in cri-o, published on 19 Sep 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Incorrect handling of the supplementary groups in the CRI-O container engine might lead to sensitive information disclosure or possible data modification if an attacker has direct access to the affected container where supplementary groups are used to set access permissions and is able to execute a binary code in that container.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2022-2995?

3 open source packages ship an affected version, including github.com/cri-o/cri-o. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/cri-o/cri-o` | Go | All versions | 1.25.0 |
| `github.com/cri-o/cri-o` | Go | All versions | 1.25.0 |
| `github.com/cri-o/cri-o` | Go | All versions | 1.25.0 |
| `cri-o` | Red Hat:openshift:4.10::el7 | All versions | 0:1.23.5-11.rhaos4.10.gitfc32aac.el7 |
| `cri-o-debuginfo` | Red Hat:openshift:4.10::el7 | All versions | 0:1.23.5-11.rhaos4.10.gitfc32aac.el7 |
| `cri-o` | Red Hat:openshift:4.10::el8 | All versions | 0:1.23.5-11.rhaos4.10.gitfc32aac.el8 |
| `cri-o-debuginfo` | Red Hat:openshift:4.10::el8 | All versions | 0:1.23.5-11.rhaos4.10.gitfc32aac.el8 |
| `cri-o-debugsource` | Red Hat:openshift:4.10::el8 | All versions | 0:1.23.5-11.rhaos4.10.gitfc32aac.el8 |

Products: Kubernetes Cri-O.

## How do I fix CVE-2022-2995?

Upgrade github.com/cri-o/cri-o to 1.25.0 or later.

## Is CVE-2022-2995 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-2995 exists.

## Other vulnerabilities in cri-o

- [CVE-2022-0811](https://insights.sbomify.com/CVE-2022-0811/): Code Injection in CRI-O (high 8.8)
- [CVE-2018-1000400](https://insights.sbomify.com/CVE-2018-1000400/): Privilege escalation in n/a (high 8.8)
- [CVE-2024-5154](https://insights.sbomify.com/CVE-2024-5154/): Cri-o: malicious container can create symlink on host (high 8.1)
- [CVE-2022-3466](https://insights.sbomify.com/CVE-2022-3466/): Cri-o: security regression of cve-2022-27652 (medium 4.8)
- [CVE-2022-0532](https://insights.sbomify.com/CVE-2022-0532/): Incorrect Permission Assignment for Critical Resource in CRI-O (medium 4.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-2995 and fix it if it is affected.

What it is: CVE-2022-2995 is a high-severity missing authorization vulnerability in cri-o, published on 19 Sep 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-2995 exists.

Affected packages and fixed versions:
- github.com/cri-o/cri-o (Go): affected all versions; fixed in 1.25.0
- github.com/cri-o/cri-o (Go): affected all versions; fixed in 1.25.0
- github.com/cri-o/cri-o (Go): affected all versions; fixed in 1.25.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-2995/ (Markdown: https://insights.sbomify.com/CVE-2022-2995/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-2995
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-2995
- OSV: https://osv.dev/vulnerability/CVE-2022-2995

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-2995/
Summaries are generated and may contain mistakes; the official description above is the record.
