# CVE-2022-2996: python-scciclient vulnerable to Man-in-the-middle (MITM) attacks

> Attackers can perform Man-in-the-Middle attacks due to missing certificate verification in python-scciclient HTTPS connections.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Sep 2022
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2022-2996, DLA-3180-1, GHSA-rf3f-3p37-2qh4, PYSEC-2022-43152, RHSA-2022:8854, RHSA-2022:8868, RHSA-2023:0276, UBUNTU-CVE-2022-2996

## What is CVE-2022-2996?

CVE-2022-2996 is a high-severity vulnerability in Debian Debian Linux, published on 1 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A flaw was found in the python-scciclient when making an HTTPS connection to a server where the server's certificate would not be verified. This issue opens up the connection to possible Man-in-the-middle (MITM) attacks.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2022-2996?

3 open source packages ship an affected version, including python-scciclient. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `python-scciclient` | PyPI | All versions | 0.12.0 |
| `python-scciclient` | PyPI | All versions | 0.12.0 |
| `python-scciclient` | PyPI | All versions | 0.12.0 |
| `python-scciclient` | Red Hat:openstack:16.1::el8 | All versions | 0:0.9.1-2.20220111031440.el8ost |
| `python3-scciclient` | Red Hat:openstack:16.1::el8 | All versions | 0:0.9.1-2.20220111031440.el8ost |
| `python-scciclient` | Red Hat:openstack:16.2::el8 | All versions | 0:0.9.1-2.20220111031440.el8ost |
| `python-scciclient` | Red Hat:openstack:17.0::el9 | All versions | 0:0.10.2-0.20220830130628.b8e6e34.el9ost |
| `python3-scciclient` | Red Hat:openstack:17.0::el9 | All versions | 0:0.10.2-0.20220830130628.b8e6e34.el9ost |

Products: Debian Debian Linux, Python-Scciclient Project Python-Scciclient.

## How do I fix CVE-2022-2996?

Upgrade python-scciclient to 0.12.0 or later.

## Is CVE-2022-2996 being exploited?

There is no known exploitation of CVE-2022-2996 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-2996 and fix it if it is affected.

What it is: CVE-2022-2996 is a high-severity vulnerability in Debian Debian Linux, published on 1 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-2996 in the wild and no public exploit code.

Affected packages and fixed versions:
- python-scciclient (PyPI): affected all versions; fixed in 0.12.0
- python-scciclient (PyPI): affected all versions; fixed in 0.12.0
- python-scciclient (PyPI): affected all versions; fixed in 0.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-2996/ (Markdown: https://insights.sbomify.com/CVE-2022-2996/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-2996
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-2996
- OSV: https://osv.dev/vulnerability/CVE-2022-2996

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-2996/
Summaries are generated and may contain mistakes; the official description above is the record.
