# CVE-2022-29970: sinatra does not validate expanded path matches

> Attackers can read arbitrary files outside the public directory by exploiting path traversal in Sinatra's static file serving.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 May 2022
- **Updated:** 4 Nov 2025
- **Also known as:** ALSA-2022:4587, ALSA-2022:4661, DEBIAN-CVE-2022-29970, DLA-3166-1, GHSA-qp49-3pvw-x4m5, MGASA-2022-0280, RHSA-2022:2253, RHSA-2022:2255, RHSA-2022:2256, RHSA-2022:4587, RHSA-2022:4661, RLSA-2022:4661, SUSE-SU-2022:2046-1, UBUNTU-CVE-2022-29970

## What is CVE-2022-29970?

CVE-2022-29970 is a high-severity path traversal vulnerability in Debian Debian Linux, published on 2 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Sinatra before 2.2.0 does not validate that the expanded path matches public_dir when serving static files.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2022-29970?

2 open source packages ship an affected version, including sinatra. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sinatra` | RubyGems | All versions | 2.2.0 |
| `sinatra` | RubyGems | All versions | 2.2.0 |
| `pcs` | AlmaLinux:8 | All versions | 0.10.12-6.el8.alma |
| `pcs-snmp` | AlmaLinux:8 | All versions | 0.10.12-6.el8.alma |
| `pcs` | AlmaLinux:9 | All versions | 0.11.1-10.el9 |
| `pcs-snmp` | AlmaLinux:9 | All versions | 0.11.1-10.el9 |
| `pcs` | Red Hat:enterprise_linux:8::highavailability | All versions | 0:0.10.12-6.el8_6.1 |
| `pcs-snmp` | Red Hat:enterprise_linux:8::highavailability | All versions | 0:0.10.12-6.el8_6.1 |
| `pcs` | Red Hat:enterprise_linux:8::resilientstorage | All versions | 0:0.10.12-6.el8_6.1 |
| `pcs-snmp` | Red Hat:enterprise_linux:8::resilientstorage | All versions | 0:0.10.12-6.el8_6.1 |
| `pcs` | Red Hat:enterprise_linux:9::highavailability | All versions | 0:0.11.1-10.el9_0.1 |
| `pcs-snmp` | Red Hat:enterprise_linux:9::highavailability | All versions | 0:0.11.1-10.el9_0.1 |
| `pcs` | Red Hat:enterprise_linux:9::resilientstorage | All versions | 0:0.11.1-10.el9_0.1 |
| `pcs-snmp` | Red Hat:enterprise_linux:9::resilientstorage | All versions | 0:0.11.1-10.el9_0.1 |
| `pcs` | Red Hat:rhel_e4s:8.1::highavailability | All versions | 0:0.10.2-4.el8_1.2 |
| `pcs-snmp` | Red Hat:rhel_e4s:8.1::highavailability | All versions | 0:0.10.2-4.el8_1.2 |
| `pcs` | Red Hat:rhel_eus:8.2::highavailability | All versions | 0:0.10.4-6.el8_2.2 |
| `pcs-snmp` | Red Hat:rhel_eus:8.2::highavailability | All versions | 0:0.10.4-6.el8_2.2 |
| `pcs` | Red Hat:rhel_eus:8.2::resilientstorage | All versions | 0:0.10.4-6.el8_2.2 |
| `pcs-snmp` | Red Hat:rhel_eus:8.2::resilientstorage | All versions | 0:0.10.4-6.el8_2.2 |
| `pcs` | Red Hat:rhel_eus:8.4::highavailability | All versions | 0:0.10.8-1.el8_4.1 |
| `pcs-snmp` | Red Hat:rhel_eus:8.4::highavailability | All versions | 0:0.10.8-1.el8_4.1 |
| `pcs` | Red Hat:rhel_eus:8.4::resilientstorage | All versions | 0:0.10.8-1.el8_4.1 |
| `pcs-snmp` | Red Hat:rhel_eus:8.4::resilientstorage | All versions | 0:0.10.8-1.el8_4.1 |
| `pcs` | Rocky Linux:8 | All versions | 0:0.10.12-6.el8_6.1 |
| `rubygem-sinatra` | SUSE:OpenStack Cloud Crowbar 8 | All versions | 1.4.6-3.3.1 |

Products: Debian Debian Linux, Sinatrarb Sinatra.

## How do I fix CVE-2022-29970?

Upgrade sinatra to 2.2.0 or later.

## Is CVE-2022-29970 being exploited?

There is no known exploitation of CVE-2022-29970 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-29970 and fix it if it is affected.

What it is: CVE-2022-29970 is a high-severity path traversal vulnerability in Debian Debian Linux, published on 2 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-29970 in the wild and no public exploit code.

Affected packages and fixed versions:
- sinatra (RubyGems): affected all versions; fixed in 2.2.0
- sinatra (RubyGems): affected all versions; fixed in 2.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-29970/ (Markdown: https://insights.sbomify.com/CVE-2022-29970/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-29970
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-29970
- OSV: https://osv.dev/vulnerability/CVE-2022-29970

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-29970/
Summaries are generated and may contain mistakes; the official description above is the record.
