# CVE-2022-30034: Flower OAuth authentication bypass

> Attackers can bypass OAuth authentication in Flower to invoke arbitrary Celery RPC calls or shut down task nodes.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 May 2022
- **Updated:** 9 Jul 2026
- **Also known as:** GHSA-q4qm-xhf9-4p8f, PYSEC-2022-42973, ROOT-APP-PYPI-CVE-2022-30034, UBUNTU-CVE-2022-30034

## What is CVE-2022-30034?

CVE-2022-30034 is a high-severity authentication bypass vulnerability in n/a, published on 31 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Flower, a web UI for the Celery Python RPC framework, all versions as of 05-02-2022 is vulnerable to an OAuth authentication bypass. An attacker could then access the Flower API to discover and invoke arbitrary Celery RPC calls or deny service by shutting down Celery task nodes.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2022-30034?

3 open source packages ship an affected version, including flower. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flower` | PyPI | All versions | 1.2.0 |
| `flower` | PyPI | All versions | 1.2.0 |
| `flower` | PyPI | All versions | 1.2.0 |

Products: Flower Project Flower.

## How do I fix CVE-2022-30034?

Upgrade flower to 1.2.0 or later.

## Is CVE-2022-30034 being exploited?

There is no known exploitation of CVE-2022-30034 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-16925](https://insights.sbomify.com/CVE-2019-16925/): Cross-site scripting in n/a (medium 6.1)
- [CVE-2019-16926](https://insights.sbomify.com/CVE-2019-16926/): Cross-site scripting in n/a (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-30034 and fix it if it is affected.

What it is: CVE-2022-30034 is a high-severity authentication bypass vulnerability in n/a, published on 31 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-30034 in the wild and no public exploit code.

Affected packages and fixed versions:
- flower (PyPI): affected all versions; fixed in 1.2.0
- flower (PyPI): affected all versions; fixed in 1.2.0
- flower (PyPI): affected all versions; fixed in 1.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-30034/ (Markdown: https://insights.sbomify.com/CVE-2022-30034/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-30034
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-30034
- OSV: https://osv.dev/vulnerability/CVE-2022-30034

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-30034/
Summaries are generated and may contain mistakes; the official description above is the record.
