CVE-2022-30120 Cross site scripting in Concrete CMS
Attackers can execute arbitrary scripts in older browsers with XSS protection disabled via insufficient URL sanitation in Concrete CMS.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-30120?
CVE-2022-30120 is a medium-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 24 Jun 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
XSS in /dashboard/blocks/stacks/view_details/ - old browsers only. When using an older browser with built-in XSS protection disabled, insufficient sanitation where built urls are outputted can be exploited for Concrete 8.5.7 and below as well as Concrete 9.0 through 9.0.2 to allow XSS. This cannot be exploited in modern-day web browsers due to an automatic input escape mechanism. Concrete CMS Security team ranked this vulnerability 3.1with CVSS v3.1 Vector AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N. Sanitation has been added where built urls are output. Credit to Credit to Bogdan Tiron from FORTBRIDGE (https://www.fortbridge.co.uk/ ) for reporting
Weakness: CWE-79
Which versions are affected by CVE-2022-30120?
4 open source packages ship an affected version, including concrete5/core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
concrete5/core Packagist | All versions | 8.5.8 |
concrete5/core Packagist | All versions | 8.5.8 |
concrete5/core Packagist | From 9.0.0 | 9.1.0 |
concrete5/core Packagist | From 9.0.0 | 9.1.0 |
Products include Concretecms Concrete Cms.
How do I fix CVE-2022-30120?
Upgrade concrete5/core to a fixed version for your release line: 8.5.8 or 9.1.0.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2022-30120 being exploited?
There is no known exploitation of CVE-2022-30120 in the wild and no public exploit code.
Other vulnerabilities in Concretecms Concrete Cms
- CVE-2023-48648 Concrete CMS allows unauthorized access because directories can be created with insecure permissions
- CVE-2022-21829 Code injection in concrete CMS
- CVE-2021-22958 Server-Side Request Forgery vulnerability in concrete5
- CVE-2021-40098 Path traversal in n/a
- CVE-2026-8134 Concrete CMS Vulnerable to Relative Path Traversal
Sources
Also known as GHSA-m2ww-6wv6-vw3c.