# CVE-2022-30120: Cross site scripting in Concrete CMS

> Attackers can execute arbitrary scripts in older browsers with XSS protection disabled via insufficient URL sanitation in Concrete CMS.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Jun 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-m2ww-6wv6-vw3c

## What is CVE-2022-30120?

CVE-2022-30120 is a medium-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 24 Jun 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

XSS in /dashboard/blocks/stacks/view_details/ - old browsers only. When using an older browser with built-in XSS protection disabled, insufficient sanitation where built urls are outputted can be exploited for Concrete 8.5.7 and below as well as Concrete 9.0 through 9.0.2 to allow XSS. This cannot be exploited in modern-day web browsers due to an automatic input escape mechanism. Concrete CMS Security team ranked this vulnerability 3.1with CVSS v3.1 Vector AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N. Sanitation has been added where built urls are output. Credit to Credit to Bogdan Tiron from FORTBRIDGE (https://www.fortbridge.co.uk/ ) for reporting

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-30120?

4 open source packages ship an affected version, including concrete5/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `concrete5/core` | Packagist | All versions | 8.5.8 |
| `concrete5/core` | Packagist | All versions | 8.5.8 |
| `concrete5/core` | Packagist | From 9.0.0 | 9.1.0 |
| `concrete5/core` | Packagist | From 9.0.0 | 9.1.0 |

Products: Concretecms Concrete Cms.

## How do I fix CVE-2022-30120?

Upgrade concrete5/core to a fixed version for your release line: 8.5.8 or 9.1.0.

## Is CVE-2022-30120 being exploited?

There is no known exploitation of CVE-2022-30120 in the wild and no public exploit code.

## Other vulnerabilities in Concretecms Concrete Cms

- [CVE-2023-48648](https://insights.sbomify.com/CVE-2023-48648/): Concrete CMS allows unauthorized access because directories can be created with insecure permissions (critical 9.8)
- [CVE-2022-21829](https://insights.sbomify.com/CVE-2022-21829/): Code injection in concrete CMS (critical 9.8)
- [CVE-2021-22958](https://insights.sbomify.com/CVE-2021-22958/): Server-Side Request Forgery vulnerability in concrete5 (critical 9.8)
- [CVE-2021-40098](https://insights.sbomify.com/CVE-2021-40098/): Path traversal in n/a (critical 9.8)
- [CVE-2026-8134](https://insights.sbomify.com/CVE-2026-8134/): Concrete CMS Vulnerable to Relative Path Traversal (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-30120 and fix it if it is affected.

What it is: CVE-2022-30120 is a medium-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 24 Jun 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-30120 in the wild and no public exploit code.

Affected packages and fixed versions:
- concrete5/core (Packagist): affected all versions; fixed in 8.5.8
- concrete5/core (Packagist): affected all versions; fixed in 8.5.8
- concrete5/core (Packagist): affected from 9.0.0; fixed in 9.1.0
- concrete5/core (Packagist): affected from 9.0.0; fixed in 9.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-30120/ (Markdown: https://insights.sbomify.com/CVE-2022-30120/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-30120
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-30120
- OSV: https://osv.dev/vulnerability/CVE-2022-30120

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-30120/
Summaries are generated and may contain mistakes; the official description above is the record.
