CVE-2022-30122 Denial of Service Vulnerability in Rack Multipart Parsing
Attackers can cause a denial of service in Rack by exploiting inefficient multipart parsing, affecting Ruby web applications.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-30122?
CVE-2022-30122 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 5 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A possible denial of service vulnerability exists in Rack <2.0.9.1, <2.1.4.1 and <2.2.3.1 in the multipart parsing component of Rack.
Which versions are affected by CVE-2022-30122?
6 open source packages ship an affected version, including rack. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
rack RubyGems | From 1.2 | 2.0.9.1 |
rack RubyGems | From 1.2 | 2.0.9.1 |
rack RubyGems | From 2.1 | 2.1.4.1 |
rack RubyGems | From 2.1 | 2.1.4.1 |
rack RubyGems | From 2.2 | 2.2.3.1 |
rack RubyGems | From 2.2 | 2.2.3.1 |
Products include Debian Debian Linux, Rack Project Rack.
How do I fix CVE-2022-30122?
Upgrade rack to a fixed version for your release line: 2.0.9.1, 2.1.4.1 or 2.2.3.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2022-30122 being exploited?
There is no known exploitation of CVE-2022-30122 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2022-30122, GHSA-hxqx-xwvh-44m2, UBUNTU-CVE-2022-30122.