CVE-2022-30123 Possible shell escape sequence injection vulnerability in Rack
Attackers can execute arbitrary commands via shell escape in Rack's Lint and CommonLogger components, requiring an upgrade to secure Ruby web applications.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-30123?
CVE-2022-30123 is a critical command injection vulnerability in Debian Debian Linux, published on 5 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A sequence injection vulnerability exists in Rack <2.0.9.1, <2.1.4.1 and <2.2.3.1 which could allow is a possible shell escape in the Lint and CommonLogger components of Rack.
Weakness: CWE-150
Which versions are affected by CVE-2022-30123?
6 open source packages ship an affected version, including rack. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
rack RubyGems | All versions | 2.0.9.1 |
rack RubyGems | All versions | 2.0.9.1 |
rack RubyGems | From 2.1 | 2.1.4.1 |
rack RubyGems | From 2.1 | 2.1.4.1 |
rack RubyGems | From 2.2 | 2.2.3.1 |
rack RubyGems | From 2.2 | 2.2.3.1 |
Products include Debian Debian Linux, Rack Project Rack.
How do I fix CVE-2022-30123?
Upgrade rack to a fixed version for your release line: 2.0.9.1, 2.1.4.1 or 2.2.3.1.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2022-30123 being exploited?
There is no known exploitation of CVE-2022-30123 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2022-30123, GHSA-wq4h-7r42-5hrr, UBUNTU-CVE-2022-30123.