# CVE-2022-30123: Possible shell escape sequence injection vulnerability in Rack

> Attackers can execute arbitrary commands via shell escape in Rack's Lint and CommonLogger components, requiring an upgrade to secure Ruby web applications.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Dec 2022
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2022-30123, GHSA-wq4h-7r42-5hrr, UBUNTU-CVE-2022-30123

## What is CVE-2022-30123?

CVE-2022-30123 is a critical command injection vulnerability in Debian Debian Linux, published on 5 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A sequence injection vulnerability exists in Rack <2.0.9.1, <2.1.4.1 and <2.2.3.1 which could allow is a possible shell escape in the Lint and CommonLogger components of Rack.

Weakness: CWE-150 (Improper Neutralization of Escape, Meta, or Control Sequences)

## Which versions are affected by CVE-2022-30123?

6 open source packages ship an affected version, including rack. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rack` | RubyGems | All versions | 2.0.9.1 |
| `rack` | RubyGems | All versions | 2.0.9.1 |
| `rack` | RubyGems | From 2.1 | 2.1.4.1 |
| `rack` | RubyGems | From 2.1 | 2.1.4.1 |
| `rack` | RubyGems | From 2.2 | 2.2.3.1 |
| `rack` | RubyGems | From 2.2 | 2.2.3.1 |

Products: Debian Debian Linux, Rack Project Rack.

## How do I fix CVE-2022-30123?

Upgrade rack to a fixed version for your release line: 2.0.9.1, 2.1.4.1 or 2.2.3.1.

## Is CVE-2022-30123 being exploited?

There is no known exploitation of CVE-2022-30123 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-30123 and fix it if it is affected.

What it is: CVE-2022-30123 is a critical command injection vulnerability in Debian Debian Linux, published on 5 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-30123 in the wild and no public exploit code.

Affected packages and fixed versions:
- rack (RubyGems): affected all versions; fixed in 2.0.9.1
- rack (RubyGems): affected all versions; fixed in 2.0.9.1
- rack (RubyGems): affected from 2.1; fixed in 2.1.4.1
- rack (RubyGems): affected from 2.1; fixed in 2.1.4.1
- rack (RubyGems): affected from 2.2; fixed in 2.2.3.1
- rack (RubyGems): affected from 2.2; fixed in 2.2.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-30123/ (Markdown: https://insights.sbomify.com/CVE-2022-30123/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-30123
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-30123
- OSV: https://osv.dev/vulnerability/CVE-2022-30123

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-30123/
Summaries are generated and may contain mistakes; the official description above is the record.
