CVE-2022-3018 Information disclosure in GitLab
A project maintainer can access the DataDog integration API key from webhook logs, exposing sensitive credentials.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-3018?
CVE-2022-3018 is a medium-severity vulnerability in Gitlab Gitlab, published on 28 Oct 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
An information disclosure vulnerability in GitLab CE/EE affecting all versions starting from 9.3 before 15.2.5, all versions starting from 15.3 before 15.3.4, all versions starting from 15.4 before 15.4.1 allows a project maintainer to access the DataDog integration API key from webhook logs.
Weakness: CWE-532
Which versions are affected by CVE-2022-3018?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 9.3.0 | 15.2.5, 15.3.4, 15.4.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2022-3018?
Upgrade gitlab to a fixed version for your release line: 15.2.5, 15.3.4 or 15.4.1.
Is CVE-2022-3018 being exploited?
There is no known exploitation of CVE-2022-3018 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2022-3018, GHSA-5fw4-hg92-mgm7, UBUNTU-CVE-2022-3018.