{"answers":{"affected":"2 open source packages ship an affected version, including jquery.json-viewer. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-30241 in the wild and no public exploit code.","fix":"Upgrade jquery.json-viewer to 1.5.0 or later.","what":"CVE-2022-30241 is a medium-severity cross-site scripting vulnerability in n/a, published on 4 May 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-30241 and fix it if it is affected.\n\nWhat it is: CVE-2022-30241 is a medium-severity cross-site scripting vulnerability in n/a, published on 4 May 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-30241 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- jquery.json-viewer (npm): affected all versions; fixed in 1.5.0\n- jquery.json-viewer (npm): affected all versions; fixed in 1.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-30241/ (Markdown: https://insights.sbomify.com/CVE-2022-30241/index.md)","id":"CVE-2022-30241","markdown":"https://insights.sbomify.com/CVE-2022-30241/index.md","name":"CVE-2022-30241","record":{"aliases":["GHSA-qp2q-6h9j-jg2r"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js JSON viewer","requires_auth":"none","summary":"Attackers can execute arbitrary scripts via unescaped JSON input in the jquery.json-viewer library, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"jquery_json-viewer","vendor":"jquery_json-viewer_project"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The jquery.json-viewer library through 1.4.0 for Node.js does not properly escape characters such as \u003c in a JSON object, as demonstrated by a SCRIPT element.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting in jquery.json-viewer","id":"CVE-2022-30241","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Missing authorization in n/a","id":"CVE-2022-30242"},"packages":[{"ecosystem":"npm","fixed":["1.5.0"],"introduced":["0"],"last_affected":[],"package":"jquery.json-viewer","purl":null,"source":"GHSA-qp2q-6h9j-jg2r"},{"ecosystem":"npm","fixed":["1.5.0"],"introduced":["0"],"last_affected":[],"package":"jquery.json-viewer","purl":"pkg:npm/jquery.json-viewer","source":"GHSA-qp2q-6h9j-jg2r"}],"prev":{"headline":"Command injection in n/a","id":"CVE-2022-30240"},"products":["n/a"],"published":"2022-05-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Attackers can execute arbitrary scripts via unescaped JSON input in the jquery.json-viewer library, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2022-30241/"}