{"answers":{"affected":"1 open source package ship an affected version, including pycti. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-30289 in the wild and no public exploit code.","fix":"Upgrade pycti to 5.3.0 or later.","what":"CVE-2022-30289 is a medium-severity cross-site scripting vulnerability in n/a, published on 5 Jul 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-30289 and fix it if it is affected.\n\nWhat it is: CVE-2022-30289 is a medium-severity cross-site scripting vulnerability in n/a, published on 5 Jul 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-30289 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pycti (PyPI): affected all versions; fixed in 5.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-30289/ (Markdown: https://insights.sbomify.com/CVE-2022-30289/index.md)","id":"CVE-2022-30289","markdown":"https://insights.sbomify.com/CVE-2022-30289/index.md","name":"CVE-2022-30289","record":{"aliases":["GHSA-5w4w-f8gg-22rw","PYSEC-2022-43185"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenCTI threat intelligence","requires_auth":"low_privilege","summary":"Attackers can inject malicious scripts via file uploads in OpenCTI's Data Import feature, leading to code execution when victims view the file.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"opencti","vendor":"citeum"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A stored Cross-site Scripting (XSS) vulnerability was identified in the Data Import functionality of OpenCTI through 5.2.4. An attacker can abuse the vulnerability to upload a malicious file that will then be executed by a victim when they open the file location.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site scripting in n/a","id":"CVE-2022-30289","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":1,"n_references":2,"next":{"headline":"Missing authorization in n/a","id":"CVE-2022-30290"},"packages":[{"ecosystem":"PyPI","fixed":["5.3.0"],"introduced":["0"],"last_affected":[],"package":"pycti","purl":"pkg:pypi/pycti","source":"PYSEC-2022-43185"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2022-30288"},"products":["n/a"],"published":"2022-07-05","related":[{"cvss_score":9.8,"headline":"OpenCTI privilege escalation and unauthenticated access via default admin account","id":"CVE-2026-27960","kev_date_added":null,"published":"2026-05-05"},{"cvss_score":9.1,"headline":"OpenCTI affected by RCE via notifier template","id":"CVE-2026-39980","kev_date_added":null,"published":"2026-04-09"},{"cvss_score":9.1,"headline":"OpenCTI has remote code execution and sensitive secrets exposed through web hook","id":"CVE-2025-24977","kev_date_added":null,"published":"2025-05-05"},{"cvss_score":8.3,"headline":"OpenCTI Authenticated Privilege Escalation","id":"CVE-2024-26139","kev_date_added":null,"published":"2024-05-23"},{"cvss_score":8.1,"headline":"OpenCTI's lack of Rate Limit lead to OTP brute forcing","id":"CVE-2024-45404","kev_date_added":null,"published":"2024-12-11"},{"cvss_score":7.7,"headline":"OpenCTI has a Semi-Blind SSRF via Unvalidated External URL in Data Ingestion Feature","id":"CVE-2026-21887","kev_date_added":null,"published":"2026-03-12"},{"cvss_score":7.6,"headline":"OpenCTI vulnerable to Denial of Service through web hook","id":"CVE-2025-26621","kev_date_added":null,"published":"2025-05-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Attackers can inject malicious scripts via file uploads in OpenCTI's Data Import feature, leading to code execution when victims view the file.","url":"https://insights.sbomify.com/CVE-2022-30289/"}