CVE-2022-3031 Auth bypass in GitLab

Low 3.7 Published Updated

Attackers can bypass 2FA and guess user passwords via brute force on a specific endpoint, leading to account takeover.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-3031?

CVE-2022-3031 is a low-severity authentication bypass vulnerability in Gitlab Gitlab, published on 17 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions before 15.1.6, all versions starting from 15.2 before 15.2.4, all versions starting from 15.3 before 15.3.2. It may be possible for an attacker to guess a user's password by brute force by sending crafted requests to a specific endpoint, even if the victim user has 2FA enabled on their account.

Weakness: CWE-307

Which versions are affected by CVE-2022-3031?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiAll versions15.1.6, 15.2.4, 15.3.2

Products include Gitlab Gitlab.

How do I fix CVE-2022-3031?

Upgrade gitlab to a fixed version for your release line: 15.1.6, 15.2.4 or 15.3.2.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2022-3031 being exploited?

There is no known exploitation of CVE-2022-3031 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-3031, GHSA-hchv-vv89-9pxp, UBUNTU-CVE-2022-3031.

Is CVE-2022-3031 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free