# CVE-2022-30322: Denial of service in n/a

> Attackers can cause resource exhaustion in go-getter by sending malicious HTTP responses, leading to denial of service.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 May 2022
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2022-30322, MINI-23v2-j367-pjc9, MINI-25p9-mc4v-6v7x, MINI-26hw-r97m-6cvh, MINI-27jj-w4r5-9ww8, MINI-29qm-g8c4-xxwp, MINI-2crc-xq43-pqj2, MINI-2v9q-6v43-hq5q, MINI-34qj-m6c8-q8qf, MINI-39g3-x25q-67gp, MINI-3crg-88p9-phcq, MINI-3f4c-62g9-578m, MINI-3jcm-c6fm-99h6, MINI-3mcc-6257-h52g, MINI-3q78-8hw4-pjxj, MINI-428p-35v8-783v, MINI-44w9-fm7q-mp8f, MINI-4623-6gr9-hqx7, MINI-46c4-xhrf-fpch, MINI-489w-ww7j-7433, MINI-4j73-pccg-c842, MINI-4wxc-ghhg-ww7r, MINI-53jj-6gcr-ffpr, MINI-5g5p-3r2g-m672, MINI-5qrq-2xxj-7rf5, MINI-6g7p-39rq-97vh, MINI-74hh-p9xp-7vj8, MINI-78pm-r363-5839, MINI-7g8x-qxcm-fq3m, MINI-7pgc-j9xf-g8cf, MINI-7r9v-3cgj-gcf4, MINI-7wjg-m5mq-xm8h, MINI-7xcx-vxm9-x94r, MINI-87f3-g4r5-qpgm, MINI-8qjj-w5q4-cr48, MINI-8wj6-5p9p-9v5f, MINI-8wrh-5rm5-x2v6, MINI-94q3-mfvc-fw3x, MINI-9hhw-qwwc-77x5, MINI-9m82-jhr4-89hc, MINI-9mf7-978c-gq7g, MINI-9r44-cw75-gfg6, MINI-c2pq-f82f-g46f, MINI-c5hx-65jw-5m49, MINI-cff5-5g69-r7vr, MINI-cfr3-f7v7-6g4q, MINI-cgfv-j7p6-r7jc, MINI-cwr7-x5gw-qfv2, MINI-cxf6-qcjh-f3hf, MINI-fg79-5wpj-c45w, MINI-fp68-r2pv-mmp3, MINI-fvhr-48pv-rq33, MINI-g2fv-9wjf-cvfg, MINI-g4c2-c2qh-6qpx, MINI-g64x-hhw5-6h82, MINI-g75r-3gq6-rjf3, MINI-gcr3-q44m-5f6f, MINI-h465-gv84-v85p, MINI-h9mw-xxrp-2284, MINI-hf43-93g7-4f73, MINI-hfxq-m698-7h4j, MINI-hp77-29r7-r3mq, MINI-hx75-qwwp-h355, MINI-j94f-4qgv-g8r5, MINI-jgf4-vg82-c26f, MINI-jqp7-v5j4-w9xv, MINI-m2mr-qw53-q89q, MINI-m377-hwrx-x3w9, MINI-m8fw-37gp-32rr, MINI-m94w-687c-4c2x, MINI-mg8g-62c3-cx7w, MINI-mh87-2w7h-v6w2, MINI-mjqj-3r47-w4g3, MINI-mvxq-54w6-q2vq, MINI-p4p2-7648-pqg2, MINI-p77f-g3p7-8548, MINI-pc4j-h6vr-hm48, MINI-pmvh-ww38-42x6, MINI-pr3v-8gr2-hvwf, MINI-prjw-mgjj-r5wv, MINI-prvw-62hh-p4hp, MINI-pwfx-r853-2r35, MINI-pxc9-9pjr-fr97, MINI-q4gm-m749-3jxm, MINI-q6c5-x6c4-5588, MINI-q6xc-rgcm-m886, MINI-q7cc-g8j9-rmrg, MINI-q7wr-54jv-59wx, MINI-q8c5-x59r-wcq2, MINI-qcr3-v2v7-x5j8, MINI-qj2g-869x-vjxj, MINI-qpfx-r5fv-xhcq, MINI-qvv7-pggm-7r46, MINI-qww9-v7m8-pxvw, MINI-r42h-hf85-f5fq, MINI-r6q3-q3p3-8jwx, MINI-rp35-cjfq-qh5m, MINI-rwmc-vjch-6qg3, MINI-v5p2-23mq-qcwm, MINI-v9hf-744m-hgwf, MINI-vgj5-r7h4-94rm, MINI-vgjm-vq6v-m8rr, MINI-vm4r-7j3q-9mhv, MINI-vmcv-c8jq-r7qh, MINI-vrc6-8mmh-hjfr, MINI-vrg5-4f5x-mmqq, MINI-vvf8-2c5q-xc6w, MINI-w5wm-qwhp-4grq, MINI-w63r-pj3m-pf58, MINI-w769-9j6f-rppm, MINI-wg6p-2r44-5g9p, MINI-wjpv-4jgc-xxvc, MINI-wm95-q4x5-rqwc, MINI-wp2h-686m-48hr, MINI-xc7j-qmfj-jwj7, MINI-xcpp-c972-c8g6, MINI-xhjh-4qmx-jcm9, MINI-xjfm-mx27-fgc8, UBUNTU-CVE-2022-30322

## What is CVE-2022-30322?

CVE-2022-30322 is a high-severity denial of service vulnerability in n/a, published on 25 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

go-getter up to 1.5.11 and 2.0.2 allowed asymmetric resource exhaustion when go-getter processed malicious HTTP responses. Fixed in 1.6.1 and 2.1.0.

## Which versions are affected by CVE-2022-30322?

It affects 1 product.


Products: Hashicorp Go-Getter.

## How do I fix CVE-2022-30322?

Upgrade to a fixed version.

## Is CVE-2022-30322 being exploited?

There is no known exploitation of CVE-2022-30322 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2024-3817](https://insights.sbomify.com/CVE-2024-3817/): HashiCorp go-getter Vulnerable to Argument Injection When Fetching Remote Default Git Branches (critical 9.8)
- [CVE-2022-26945](https://insights.sbomify.com/CVE-2022-26945/): Server-side request forgery in n/a (critical 9.8)
- [CVE-2022-30321](https://insights.sbomify.com/CVE-2022-30321/): Path traversal in n/a (high 8.6)
- [CVE-2022-30323](https://insights.sbomify.com/CVE-2022-30323/): Denial of service in n/a (high 8.6)
- [CVE-2024-6257](https://insights.sbomify.com/CVE-2024-6257/): HashiCorp go-getter Vulnerable to Code Execution On Git Update Via Git Config Manipulation (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-30322 and fix it if it is affected.

What it is: CVE-2022-30322 is a high-severity denial of service vulnerability in n/a, published on 25 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-30322 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-30322/ (Markdown: https://insights.sbomify.com/CVE-2022-30322/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-30322
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-30322
- OSV: https://osv.dev/vulnerability/CVE-2022-30322

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-30322/
Summaries are generated and may contain mistakes; the official description above is the record.
