CVE-2022-30323 Denial of service in n/a

High 8.6 Published Updated

An attacker can cause a denial of service by providing a password-protected ZIP file to the go-getter library, crashing the application.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-30323?

CVE-2022-30323 is a high-severity denial of service vulnerability in n/a, published on 25 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

go-getter up to 1.5.11 and 2.0.2 panicked when processing password-protected ZIP files. Fixed in 1.6.1 and 2.1.0.

Which versions are affected by CVE-2022-30323?

It affects 1 product.

Products include Hashicorp Go-Getter.

How do I fix CVE-2022-30323?

Upgrade to a fixed version.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2022-30323 being exploited?

There is no known exploitation of CVE-2022-30323 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2022-30323, MINI-22xm-4468-j4cf, MINI-2frf-hr9w-q49q, MINI-2h92-3vff-3h7j, MINI-2m98-3ww3-v7w7, MINI-2rh4-w52x-325j and 113 more.

Is CVE-2022-30323 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free