# CVE-2022-30324: Privilege escalation in Hashicorp Nomad

> Attackers can escalate privileges on client agents via job artifact stanzas due to underlying go-getter vulnerabilities in HashiCorp Nomad.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 May 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-526x-rm7j-v389, GO-2022-0732, UBUNTU-CVE-2022-30324

## What is CVE-2022-30324?

CVE-2022-30324 is a critical vulnerability in n/a, published on 27 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

HashiCorp Nomad and Nomad Enterprise version 0.2.0 up to 1.3.0 were impacted by go-getter vulnerabilities enabling privilege escalation through the artifact stanza in submitted jobs onto the client agent host. Fixed in 1.1.14, 1.2.8, and 1.3.1.

## Which versions are affected by CVE-2022-30324?

7 open source packages ship an affected version, including github.com/hashicorp/nomad. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/nomad` | Go | From 0.2.0 | 1.1.14, 1.2.8, 1.3.1 |
| `github.com/hashicorp/nomad` | Go | From 0.2.0 | 1.1.14 |
| `github.com/hashicorp/nomad` | Go | From 0.2.0 | 1.1.14 |
| `github.com/hashicorp/nomad` | Go | From 1.2.0 | 1.2.8 |
| `github.com/hashicorp/nomad` | Go | From 1.2.0 | 1.2.8 |
| `github.com/hashicorp/nomad` | Go | From 1.3.0 | 1.3.1 |
| `github.com/hashicorp/nomad` | Go | From 1.3.0 | 1.3.1 |

Products: Hashicorp Nomad.

## How do I fix CVE-2022-30324?

Upgrade github.com/hashicorp/nomad to a fixed version for your release line: 1.1.14, 1.2.8 or 1.3.1.

## Is CVE-2022-30324 being exploited?

There is no known exploitation of CVE-2022-30324 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-1782](https://insights.sbomify.com/CVE-2023-1782/): Nomad Unauthenticated Client Agent HTTP Request Privilege Escalation (critical 10.0)
- [CVE-2020-7956](https://insights.sbomify.com/CVE-2020-7956/): Improper Certificate Validation in HashiCorp Nomad (critical 9.8)
- [CVE-2019-12618](https://insights.sbomify.com/CVE-2019-12618/): Hashicorp Nomad Access Control Issues (critical 9.8)
- [CVE-2020-27195](https://insights.sbomify.com/CVE-2020-27195/): Use After Free in HashiCorp Nomad (critical 9.1)
- [CVE-2021-43415](https://insights.sbomify.com/CVE-2021-43415/): Improper Authentication in HashiCorp Nomad (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-30324 and fix it if it is affected.

What it is: CVE-2022-30324 is a critical vulnerability in n/a, published on 27 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-30324 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/nomad (Go): affected from 0.2.0; fixed in 1.1.14, 1.2.8, 1.3.1
- github.com/hashicorp/nomad (Go): affected from 0.2.0; fixed in 1.1.14
- github.com/hashicorp/nomad (Go): affected from 0.2.0; fixed in 1.1.14
- github.com/hashicorp/nomad (Go): affected from 1.2.0; fixed in 1.2.8
- github.com/hashicorp/nomad (Go): affected from 1.2.0; fixed in 1.2.8
- github.com/hashicorp/nomad (Go): affected from 1.3.0; fixed in 1.3.1
- github.com/hashicorp/nomad (Go): affected from 1.3.0; fixed in 1.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-30324/ (Markdown: https://insights.sbomify.com/CVE-2022-30324/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-30324
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-30324
- OSV: https://osv.dev/vulnerability/CVE-2022-30324

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-30324/
Summaries are generated and may contain mistakes; the official description above is the record.
