# CVE-2022-3035: Cross-site Scripting (XSS) - Stored in snipe/snipe-it

> Attackers can inject malicious scripts into Snipe-IT asset management system, potentially stealing user sessions or executing code.

- **Severity:** Medium 5.9 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Aug 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-rff2-vqm3-jpv5

## What is CVE-2022-3035?

CVE-2022-3035 is a medium-severity cross-site scripting vulnerability in Snipeitapp Snipe-It, published on 29 Aug 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Cross-site Scripting (XSS) - Stored in GitHub repository snipe/snipe-it prior to v6.0.11.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-3035?

2 open source packages ship an affected version, including snipe/snipe-it. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `snipe/snipe-it` | Packagist | All versions | 6.0.11 |
| `snipe/snipe-it` | Packagist | All versions | 6.0.11 |

Products: Snipeitapp Snipe-It.

## How do I fix CVE-2022-3035?

Upgrade snipe/snipe-it to 6.0.11 or later.

## Is CVE-2022-3035 being exploited?

There is no known exploitation of CVE-2022-3035 in the wild and no public exploit code.

## Other vulnerabilities in Snipeitapp Snipe-It

- [CVE-2025-63601](https://insights.sbomify.com/CVE-2025-63601/): File upload in n/a (critical 9.9)
- [CVE-2026-37709](https://insights.sbomify.com/CVE-2026-37709/): Snipe-IT has insecure permissions in file uploads (critical 9.8)
- [CVE-2026-86738](https://insights.sbomify.com/CVE-2026-86738/): Snipe-IT before 8.7.0 CSS Injection via Custom CSS (critical 9.3)
- [CVE-2026-116199](https://insights.sbomify.com/CVE-2026-116199/): Snipe-IT before 8.6.3 Authentication Bypass via Google SSO Callback (critical 9.2)
- [CVE-2022-1380](https://insights.sbomify.com/CVE-2022-1380/): Stored Cross Site Scripting vulnerability in Item name parameter in snipe/snipe-it (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-3035 and fix it if it is affected.

What it is: CVE-2022-3035 is a medium-severity cross-site scripting vulnerability in Snipeitapp Snipe-It, published on 29 Aug 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-3035 in the wild and no public exploit code.

Affected packages and fixed versions:
- snipe/snipe-it (Packagist): affected all versions; fixed in 6.0.11
- snipe/snipe-it (Packagist): affected all versions; fixed in 6.0.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-3035/ (Markdown: https://insights.sbomify.com/CVE-2022-3035/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-3035
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-3035
- OSV: https://osv.dev/vulnerability/CVE-2022-3035

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-3035/
Summaries are generated and may contain mistakes; the official description above is the record.
