{"answers":{"affected":"1 open source package ship an affected version, including apache. It affects 3 products.","exploited":"There is no known exploitation of CVE-2022-30522 in the wild and no public exploit code.","fix":"Upgrade apache to 2.4.54 or later.","what":"CVE-2022-30522 is a high-severity denial of service vulnerability in Apache Http Server, published on 8 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-30522 and fix it if it is affected.\n\nWhat it is: CVE-2022-30522 is a high-severity denial of service vulnerability in Apache Http Server, published on 8 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-30522 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache (Bitnami): affected from 2.4.53; fixed in 2.4.54\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-30522/ (Markdown: https://insights.sbomify.com/CVE-2022-30522/index.md)","id":"CVE-2022-30522","markdown":"https://insights.sbomify.com/CVE-2022-30522/index.md","name":"CVE-2022-30522","record":{"aliases":["ALPINE-CVE-2022-30522","BIT-apache-2022-30522","CLEANSTART-2026-SW90026","CLSA-2025-1739823342","CLSA-2025-1741635876","DEBIAN-CVE-2022-30522","GHSA-jwh2-hhpr-vq5r","UBUNTU-CVE-2022-30522","USN-5487-2"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache HTTP Server","requires_auth":"none","summary":"Attackers can cause a denial of service in Apache HTTP Server by triggering excessive memory allocations in mod_sed when processing large inputs.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"http_server","vendor":"apache"},{"product":"fedora","vendor":"fedoraproject"},{"product":"clustered_data_ontap","vendor":"netapp"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"},{"id":"CWE-789","name":"Memory Allocation with Excessive Size Value"}],"description":"If Apache HTTP Server 2.4.53 is configured to do transformations with mod_sed in contexts where the input to mod_sed may be very large, mod_sed may make excessively large memory allocations and trigger an abort.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"mod_sed denial of service","id":"CVE-2022-30522","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"apache:http_server","products":["apache:http_server","fedoraproject:fedora","netapp:clustered_data_ontap"],"type":"denial_of_service","year":"2022"},"n_packages":1,"n_references":6,"next":{"headline":"Privilege escalation in Trend Micro Password Manager","id":"CVE-2022-30523"},"packages":[{"ecosystem":"Bitnami","fixed":["2.4.54"],"introduced":["2.4.53"],"last_affected":[],"package":"apache","purl":"pkg:bitnami/apache","source":"BIT-apache-2022-30522"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2022-30521"},"products":["Apache HTTP Server"],"published":"2022-06-08","related":[{"cvss_score":9.8,"headline":"Apache HTTP Server Path Traversal","id":"CVE-2021-42013","kev_date_added":"2021-11-03","published":"2021-10-07"},{"cvss_score":9.1,"headline":"Apache HTTP Server Improper Escaping of Output","id":"CVE-2024-38475","kev_date_added":"2025-05-01","published":"2024-07-01"},{"cvss_score":9,"headline":"Apache HTTP Server-Side Request Forgery (SSRF)","id":"CVE-2021-40438","kev_date_added":"2021-12-01","published":"2021-09-16"},{"cvss_score":7.8,"headline":"Apache HTTP Server Privilege Escalation","id":"CVE-2019-0211","kev_date_added":"2021-11-03","published":"2019-04-08"},{"cvss_score":7.5,"headline":"Apache HTTP Server Path Traversal","id":"CVE-2021-41773","kev_date_added":"2021-11-03","published":"2021-10-05"},{"cvss_score":10,"headline":"Use after free in n/a","id":"CVE-2010-0425","kev_date_added":null,"published":"2010-03-05"},{"cvss_score":10,"headline":"Auth bypass in n/a","id":"CVE-2005-2700","kev_date_added":null,"published":"2005-09-06"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Apache Software Foundation"]},"summary":"Attackers can cause a denial of service in Apache HTTP Server by triggering excessive memory allocations in mod_sed when processing large inputs.","url":"https://insights.sbomify.com/CVE-2022-30522/"}