# CVE-2022-30522: mod_sed denial of service

> Attackers can cause a denial of service in Apache HTTP Server by triggering excessive memory allocations in mod_sed when processing large inputs.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jun 2022
- **Updated:** 3 Aug 2024
- **Also known as:** ALPINE-CVE-2022-30522, BIT-apache-2022-30522, CLEANSTART-2026-SW90026, CLSA-2025-1739823342, CLSA-2025-1741635876, DEBIAN-CVE-2022-30522, GHSA-jwh2-hhpr-vq5r, UBUNTU-CVE-2022-30522, USN-5487-2

## What is CVE-2022-30522?

CVE-2022-30522 is a high-severity denial of service vulnerability in Apache Http Server, published on 8 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

If Apache HTTP Server 2.4.53 is configured to do transformations with mod_sed in contexts where the input to mod_sed may be very large, mod_sed may make excessively large memory allocations and trigger an abort.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-789 (Memory Allocation with Excessive Size Value)

## Which versions are affected by CVE-2022-30522?

1 open source package ship an affected version, including apache. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache` | Bitnami | From 2.4.53 | 2.4.54 |

Products: Apache Http Server, Fedoraproject Fedora, Netapp Clustered Data Ontap.

## How do I fix CVE-2022-30522?

Upgrade apache to 2.4.54 or later.

## Is CVE-2022-30522 being exploited?

There is no known exploitation of CVE-2022-30522 in the wild and no public exploit code.

## Other vulnerabilities in Apache Http Server

- [CVE-2021-42013](https://insights.sbomify.com/CVE-2021-42013/): Apache HTTP Server Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2024-38475](https://insights.sbomify.com/CVE-2024-38475/): Apache HTTP Server Improper Escaping of Output (critical 9.1, exploited in the wild)
- [CVE-2021-40438](https://insights.sbomify.com/CVE-2021-40438/): Apache HTTP Server-Side Request Forgery (SSRF) (critical 9.0, exploited in the wild)
- [CVE-2019-0211](https://insights.sbomify.com/CVE-2019-0211/): Apache HTTP Server Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2021-41773](https://insights.sbomify.com/CVE-2021-41773/): Apache HTTP Server Path Traversal (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-30522 and fix it if it is affected.

What it is: CVE-2022-30522 is a high-severity denial of service vulnerability in Apache Http Server, published on 8 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-30522 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache (Bitnami): affected from 2.4.53; fixed in 2.4.54

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-30522/ (Markdown: https://insights.sbomify.com/CVE-2022-30522/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-30522
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-30522
- OSV: https://osv.dev/vulnerability/CVE-2022-30522

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-30522/
Summaries are generated and may contain mistakes; the official description above is the record.
