{"answers":{"affected":"1 open source package ship an affected version, including nginx-ingress-controller. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-30535 in the wild and no public exploit code.","fix":"Upgrade nginx-ingress-controller to 2.3.0 or later.","what":"CVE-2022-30535 is a medium-severity vulnerability in F5 NGINX Ingress Controller, published on 4 Aug 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-30535 and fix it if it is affected.\n\nWhat it is: CVE-2022-30535 is a medium-severity vulnerability in F5 NGINX Ingress Controller, published on 4 Aug 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-30535 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nginx-ingress-controller (Bitnami): affected from 1.0.0; fixed in 2.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-30535/ (Markdown: https://insights.sbomify.com/CVE-2022-30535/index.md)","id":"CVE-2022-30535","markdown":"https://insights.sbomify.com/CVE-2022-30535/index.md","name":"CVE-2022-30535","record":{"aliases":["BIT-nginx-ingress-controller-2022-30535","GHSA-cmrv-mf45-jw6v"],"analysis":{"component_type":"container_or_infrastructure","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"NGINX Ingress Controller","requires_auth":"low_privilege","summary":"Authorized attackers can access secrets available to the NGINX Ingress Controller by creating or updating ingress objects.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"f5","cpe":[{"product":"nginx_ingress_controller","vendor":"f5"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"In versions 2.x before 2.3.0 and all versions of 1.x, An attacker authorized to create or update ingress objects can obtain the secrets available to the NGINX Ingress Controller. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"NGINX Ingress Controller vulnerability CVE-2022-30535","id":"CVE-2022-30535","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"information_disclosure","year":"2022"},"n_packages":1,"n_references":1,"next":{"headline":"WordPress WP Maintenance plugin \u003c= 6.0.7 - Authenticated Stored Cross-Site Scripting (XSS) vulnerability","id":"CVE-2022-30536"},"packages":[{"ecosystem":"Bitnami","fixed":["2.3.0"],"introduced":["1.0.0"],"last_affected":[],"package":"nginx-ingress-controller","purl":"pkg:bitnami/nginx-ingress-controller","source":"BIT-nginx-ingress-controller-2022-30535"}],"prev":{"headline":"Command injection in AVideo","id":"CVE-2022-30534"},"products":["NGINX Ingress Controller"],"published":"2022-08-04","related":[{"cvss_score":8.7,"headline":"NGINX Ingress Controller vulnerability","id":"CVE-2026-55723","kev_date_added":null,"published":"2026-07-15"},{"cvss_score":8.7,"headline":"NGINX Ingress Controller vulnerability","id":"CVE-2025-14727","kev_date_added":null,"published":"2025-12-17"},{"cvss_score":7.1,"headline":"NGINX Ingress Controller vulnerability","id":"CVE-2026-52865","kev_date_added":null,"published":"2026-07-15"},{"cvss_score":7,"headline":"NGINX ngx_http_hls_module vulnerability CVE-2022-41743","id":"CVE-2022-41743","kev_date_added":null,"published":"2022-10-19"},{"cvss_score":6.5,"headline":"Security feature bypass in NGINX Ingress Controller","id":"CVE-2021-23055","kev_date_added":null,"published":"2022-04-21"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["F5"]},"summary":"Authorized attackers can access secrets available to the NGINX Ingress Controller by creating or updating ingress objects.","url":"https://insights.sbomify.com/CVE-2022-30535/"}