# CVE-2022-30556: Information Disclosure in mod_lua with websockets

> An attacker can read sensitive memory contents via mod_lua websockets due to incorrect buffer length handling in Apache HTTP Server.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jun 2022
- **Updated:** 3 Aug 2024
- **Also known as:** ALPINE-CVE-2022-30556, BIT-apache-2022-30556, CLEANSTART-2026-MY79414, DEBIAN-CVE-2022-30556, GHSA-gvrr-g8v5-hjqr

## What is CVE-2022-30556?

CVE-2022-30556 is a high-severity vulnerability in Apache Http Server, published on 8 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache HTTP Server 2.4.53 and earlier may return lengths to applications calling r:wsread() that point past the end of the storage allocated for the buffer.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-30556?

1 open source package ship an affected version, including apache. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache` | Bitnami | All versions | 2.4.54 |

Products: Apache Http Server, Fedoraproject Fedora, Netapp Clustered Data Ontap.

## How do I fix CVE-2022-30556?

Upgrade apache to 2.4.54 or later.

## Is CVE-2022-30556 being exploited?

There is no known exploitation of CVE-2022-30556 in the wild and no public exploit code.

## Other vulnerabilities in Apache Http Server

- [CVE-2021-42013](https://insights.sbomify.com/CVE-2021-42013/): Apache HTTP Server Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2024-38475](https://insights.sbomify.com/CVE-2024-38475/): Apache HTTP Server Improper Escaping of Output (critical 9.1, exploited in the wild)
- [CVE-2021-40438](https://insights.sbomify.com/CVE-2021-40438/): Apache HTTP Server-Side Request Forgery (SSRF) (critical 9.0, exploited in the wild)
- [CVE-2019-0211](https://insights.sbomify.com/CVE-2019-0211/): Apache HTTP Server Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2021-41773](https://insights.sbomify.com/CVE-2021-41773/): Apache HTTP Server Path Traversal (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-30556 and fix it if it is affected.

What it is: CVE-2022-30556 is a high-severity vulnerability in Apache Http Server, published on 8 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-30556 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache (Bitnami): affected all versions; fixed in 2.4.54

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-30556/ (Markdown: https://insights.sbomify.com/CVE-2022-30556/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-30556
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-30556
- OSV: https://osv.dev/vulnerability/CVE-2022-30556

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-30556/
Summaries are generated and may contain mistakes; the official description above is the record.
