# CVE-2022-30586: Missing authorization in n/a

> Attackers can exploit incorrect access control in Gradle Enterprise to achieve arbitrary code execution.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jun 2022
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-gradle-2022-30586, GHSA-wf74-667m-qg32

## What is CVE-2022-30586?

CVE-2022-30586 is a high-severity missing authorization vulnerability in n/a, published on 6 Jun 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Gradle Enterprise through 2022.2.2 has Incorrect Access Control that leads to code execution.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-30586?

1 open source package ship an affected version, including gradle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gradle` | Bitnami | All versions | 1.3.1 |

Products: Gradle Gradle.

## How do I fix CVE-2022-30586?

Upgrade gradle to 1.3.1 or later.

## Is CVE-2022-30586 being exploited?

There is no known exploitation of CVE-2022-30586 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-15052](https://insights.sbomify.com/CVE-2019-15052/): Information disclosure in n/a (critical 9.8)
- [CVE-2016-6199](https://insights.sbomify.com/CVE-2016-6199/): Deserialization in n/a (critical 9.8)
- [CVE-2021-29428](https://insights.sbomify.com/CVE-2021-29428/): Local privilege escalation through system temporary directory (high 8.8)
- [CVE-2026-22816](https://insights.sbomify.com/CVE-2026-22816/): Gradle fails to disable repositories which can expose builds to malicious artifacts (high 8.6)
- [CVE-2026-22865](https://insights.sbomify.com/CVE-2026-22865/): Gradle's failure to disable repositories failing to answer can expose builds to malicious artifacts (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-30586 and fix it if it is affected.

What it is: CVE-2022-30586 is a high-severity missing authorization vulnerability in n/a, published on 6 Jun 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-30586 in the wild and no public exploit code.

Affected packages and fixed versions:
- gradle (Bitnami): affected all versions; fixed in 1.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-30586/ (Markdown: https://insights.sbomify.com/CVE-2022-30586/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-30586
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-30586
- OSV: https://osv.dev/vulnerability/CVE-2022-30586

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-30586/
Summaries are generated and may contain mistakes; the official description above is the record.
