# CVE-2022-30595: Buffer over-flow in Pillow

> A heap buffer overflow in Pillow allows attackers to execute arbitrary code or cause denial of service via malicious TGA images.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 May 2022
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-pillow-2022-30595, DEBIAN-CVE-2022-30595, GHSA-hr8g-f6r6-mr22, PYSEC-2022-43145, openSUSE-SU-2024:12111-1

## What is CVE-2022-30595?

CVE-2022-30595 is a critical memory corruption vulnerability in Python Pillow, published on 25 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

libImaging/TgaRleDecode.c in Pillow 9.1.0 has a heap buffer overflow in the processing of invalid TGA image files.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2022-30595?

4 open source packages ship an affected version, including pillow and Pillow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pillow` | Bitnami | From 9.1.0 | 9.1.1 |
| `pillow` | PyPI | From 9.1.0 | 9.1.1 |
| `pillow` | PyPI | From 9.1.0 | 9.1.1 |
| `Pillow` | PyPI | From 9.1.0 | 9.1.1 |
| `python-Pillow` | openSUSE:Tumbleweed | All versions | 9.1.1-1.1 |

Products: Python Pillow.

## How do I fix CVE-2022-30595?

Upgrade pillow to 9.1.1 or later.

## Is CVE-2022-30595 being exploited?

There is no known exploitation of CVE-2022-30595 in the wild and no public exploit code.

## Other vulnerabilities in Python Pillow

- [CVE-2014-3007](https://insights.sbomify.com/CVE-2014-3007/): Pillow command injection (critical 10.0)
- [CVE-2026-96639](https://insights.sbomify.com/CVE-2026-96639/): Pillow multi-frame loaders can reuse stale native image storage after mode transitions (critical 9.8)
- [CVE-2021-25289](https://insights.sbomify.com/CVE-2021-25289/): Out of bounds write in Pillow (critical 9.8)
- [CVE-2016-4009](https://insights.sbomify.com/CVE-2016-4009/): Pillow Integer overflow in ImagingResampleHorizontal (critical 9.8)
- [CVE-2026-112393](https://insights.sbomify.com/CVE-2026-112393/): Pillow: Heap buffer overflow in _tiffWriteProc when saving TIFF to BytesIO (critical 9.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-30595 and fix it if it is affected.

What it is: CVE-2022-30595 is a critical memory corruption vulnerability in Python Pillow, published on 25 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-30595 in the wild and no public exploit code.

Affected packages and fixed versions:
- pillow (Bitnami): affected from 9.1.0; fixed in 9.1.1
- pillow (PyPI): affected from 9.1.0; fixed in 9.1.1
- pillow (PyPI): affected from 9.1.0; fixed in 9.1.1
- Pillow (PyPI): affected from 9.1.0; fixed in 9.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-30595/ (Markdown: https://insights.sbomify.com/CVE-2022-30595/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-30595
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-30595
- OSV: https://osv.dev/vulnerability/CVE-2022-30595

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-30595/
Summaries are generated and may contain mistakes; the official description above is the record.
