{"answers":{"affected":"4 open source packages ship an affected version, including @strapi/strapi and strapi. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-30618 in the wild and no public exploit code.","fix":"Upgrade @strapi/strapi to 4.1.9 or later.","what":"CVE-2022-30618 is a high-severity vulnerability in Strapi, published on 19 May 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-30618 and fix it if it is affected.\n\nWhat it is: CVE-2022-30618 is a high-severity vulnerability in Strapi, published on 19 May 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-30618 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @strapi/strapi (npm): affected all versions; fixed in 4.1.9\n- @strapi/strapi (npm): affected all versions; fixed in 4.1.9\n- strapi (npm): affected from 3.0.0; fixed in 3.6.9\n- strapi (npm): affected from 3.0.0; fixed in 3.6.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-30618/ (Markdown: https://insights.sbomify.com/CVE-2022-30618/index.md)","id":"CVE-2022-30618","markdown":"https://insights.sbomify.com/CVE-2022-30618/index.md","name":"CVE-2022-30618","record":{"aliases":["GHSA-vgj7-895j-gpr6"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["data_read","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Strapi CMS","requires_auth":"low_privilege","summary":"Authenticated admin users can leak sensitive API user data, potentially enabling account takeover and privilege escalation.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"SNPS","cpe":[{"product":"strapi","vendor":"strapi"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-212","name":"Improper Removal of Sensitive Information Before Storage or Transfer"}],"description":"An authenticated user with access to the Strapi admin panel can view private and sensitive data, such as email and password reset tokens, for API users if content types accessible to the authenticated user contain relationships to API users (from:users-permissions). There are many scenarios in which such details from API users can leak in the JSON response within the admin panel, either through a direct or indirect relationship. Access to this information enables a user to compromise these users’ accounts if the password reset API endpoints have been enabled. In a worst-case scenario, a low-privileged user could get access to a high-privileged API account, and could read and modify any data as well as block access to both the admin panel and API by revoking privileges for all other users.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Removal of Sensitive Information Before Storage or Transfer in Strapi","id":"CVE-2022-30618","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"information_disclosure","year":"2022"},"n_packages":4,"n_references":1,"next":{"headline":"Agile Point - Agile Point NX SQL injection (SQLi)","id":"CVE-2022-30619"},"packages":[{"ecosystem":"npm","fixed":["4.1.9"],"introduced":["0"],"last_affected":[],"package":"@strapi/strapi","purl":null,"source":"GHSA-vgj7-895j-gpr6"},{"ecosystem":"npm","fixed":["4.1.9"],"introduced":["0"],"last_affected":[],"package":"@strapi/strapi","purl":"pkg:npm/%40strapi/strapi","source":"GHSA-vgj7-895j-gpr6"},{"ecosystem":"npm","fixed":["3.6.9"],"introduced":["3.0.0"],"last_affected":[],"package":"strapi","purl":null,"source":"GHSA-vgj7-895j-gpr6"},{"ecosystem":"npm","fixed":["3.6.9"],"introduced":["3.0.0"],"last_affected":[],"package":"strapi","purl":"pkg:npm/strapi","source":"GHSA-vgj7-895j-gpr6"}],"prev":{"headline":"Improper Removal of Sensitive Information Before Storage or Transfer in Strapi","id":"CVE-2022-30617"},"products":["Strapi"],"published":"2022-05-19","related":[{"cvss_score":7.2,"headline":"Strapi Cleartext Storage of Sensitive Information","id":"CVE-2023-22894","kev_date_added":"2026-10-08","published":"2023-04-19"},{"cvss_score":10,"headline":"Strapi plugins vulnerable to Server-Side Template Injection and Remote Code Execution in the Users-Permissions Plugin","id":"CVE-2023-22621","kev_date_added":null,"published":"2023-04-19"},{"cvss_score":9.8,"headline":"Unrestricted Upload of File with Dangerous Type in Strapi","id":"CVE-2022-27263","kev_date_added":null,"published":"2022-04-12"},{"cvss_score":9.8,"headline":"Authorization bypass in Strapi","id":"CVE-2020-27664","kev_date_added":null,"published":"2020-10-22"},{"cvss_score":9.8,"headline":"Strapi allows unauthenticated attacker to reset admin password without valid reset token","id":"CVE-2019-18818","kev_date_added":null,"published":"2019-11-07"},{"cvss_score":9.3,"headline":"Strapi Vulnerable to SQL Injection in Content Type Builder","id":"CVE-2026-22599","kev_date_added":null,"published":"2026-05-14"},{"cvss_score":9.2,"headline":"Strapi may leak sensitive data via relational filtering due to lack of query sanitization","id":"CVE-2026-27886","kev_date_added":null,"published":"2026-05-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Strapi"]},"summary":"Authenticated admin users can leak sensitive API user data, potentially enabling account takeover and privilege escalation.","url":"https://insights.sbomify.com/CVE-2022-30618/"}