# CVE-2022-30618: Improper Removal of Sensitive Information Before Storage or Transfer in Strapi

> Authenticated admin users can leak sensitive API user data, potentially enabling account takeover and privilege escalation.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 May 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-vgj7-895j-gpr6

## What is CVE-2022-30618?

CVE-2022-30618 is a high-severity vulnerability in Strapi, published on 19 May 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An authenticated user with access to the Strapi admin panel can view private and sensitive data, such as email and password reset tokens, for API users if content types accessible to the authenticated user contain relationships to API users (from:users-permissions). There are many scenarios in which such details from API users can leak in the JSON response within the admin panel, either through a direct or indirect relationship. Access to this information enables a user to compromise these users’ accounts if the password reset API endpoints have been enabled. In a worst-case scenario, a low-privileged user could get access to a high-privileged API account, and could read and modify any data as well as block access to both the admin panel and API by revoking privileges for all other users.

Weakness: CWE-212 (Improper Removal of Sensitive Information Before Storage or Transfer)

## Which versions are affected by CVE-2022-30618?

4 open source packages ship an affected version, including @strapi/strapi and strapi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@strapi/strapi` | npm | All versions | 4.1.9 |
| `@strapi/strapi` | npm | All versions | 4.1.9 |
| `strapi` | npm | From 3.0.0 | 3.6.9 |
| `strapi` | npm | From 3.0.0 | 3.6.9 |

Products: Strapi Strapi.

## How do I fix CVE-2022-30618?

Upgrade @strapi/strapi to 4.1.9 or later.

## Is CVE-2022-30618 being exploited?

There is no known exploitation of CVE-2022-30618 in the wild and no public exploit code.

## Other vulnerabilities in Strapi

- [CVE-2023-22894](https://insights.sbomify.com/CVE-2023-22894/): Strapi Cleartext Storage of Sensitive Information (high 7.2, exploited in the wild)
- [CVE-2023-22621](https://insights.sbomify.com/CVE-2023-22621/): Strapi plugins vulnerable to Server-Side Template Injection and Remote Code Execution in the Users-Permissions Plugin (critical 10.0)
- [CVE-2022-27263](https://insights.sbomify.com/CVE-2022-27263/): Unrestricted Upload of File with Dangerous Type in Strapi (critical 9.8)
- [CVE-2020-27664](https://insights.sbomify.com/CVE-2020-27664/): Authorization bypass in Strapi (critical 9.8)
- [CVE-2019-18818](https://insights.sbomify.com/CVE-2019-18818/): Strapi allows unauthenticated attacker to reset admin password without valid reset token (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-30618 and fix it if it is affected.

What it is: CVE-2022-30618 is a high-severity vulnerability in Strapi, published on 19 May 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-30618 in the wild and no public exploit code.

Affected packages and fixed versions:
- @strapi/strapi (npm): affected all versions; fixed in 4.1.9
- @strapi/strapi (npm): affected all versions; fixed in 4.1.9
- strapi (npm): affected from 3.0.0; fixed in 3.6.9
- strapi (npm): affected from 3.0.0; fixed in 3.6.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-30618/ (Markdown: https://insights.sbomify.com/CVE-2022-30618/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-30618
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-30618
- OSV: https://osv.dev/vulnerability/CVE-2022-30618

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-30618/
Summaries are generated and may contain mistakes; the official description above is the record.
