CVE-2022-3067 Missing authorization in GitLab
Authenticated users can read arbitrary project content by exploiting an authorization flaw in the Import functionality.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-3067?
CVE-2022-3067 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 17 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue has been discovered in the Import functionality of GitLab CE/EE affecting all versions starting from 14.4 before 15.2.5, all versions starting from 15.3 before 15.3.4, all versions starting from 15.4 before 15.4.1. It was possible for an authenticated user to read arbitrary projects' content given the project's ID.
Weakness: CWE-284
Which versions are affected by CVE-2022-3067?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 14.4.0 | 15.2.5, 15.3.4, 15.4.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2022-3067?
Upgrade gitlab to a fixed version for your release line: 15.2.5, 15.3.4 or 15.4.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2022-3067 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3067 exists.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2022-3067, GHSA-mqfg-2r7h-3f8c, UBUNTU-CVE-2022-3067.