{"answers":{"affected":"3 open source packages ship an affected version, including octoprint and OctoPrint. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3068 exists.","fix":"Upgrade octoprint to 1.8.3 or later.","what":"CVE-2022-3068 is a medium-severity vulnerability in octoprint/octoprint, published on 21 Sep 2022. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-3068 and fix it if it is affected.\n\nWhat it is: CVE-2022-3068 is a medium-severity vulnerability in octoprint/octoprint, published on 21 Sep 2022. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3068 exists.\n\nAffected packages and fixed versions:\n- octoprint (PyPI): affected all versions; fixed in 1.8.3\n- octoprint (PyPI): affected all versions; fixed in 1.8.3\n- OctoPrint (PyPI): affected all versions; fixed in 1.8.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-3068/ (Markdown: https://insights.sbomify.com/CVE-2022-3068/index.md)","id":"CVE-2022-3068","markdown":"https://insights.sbomify.com/CVE-2022-3068/index.md","name":"CVE-2022-3068","record":{"aliases":["GHSA-2p75-q37p-f852","PYSEC-2022-283"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"OctoPrint server","requires_auth":"low_privilege","summary":"Attackers can exploit improper privilege management in OctoPrint to escalate privileges, requiring an upgrade to the latest version.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"octoprint","vendor":"octoprint"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.0"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"Improper Privilege Management in GitHub repository octoprint/octoprint prior to 1.8.3.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Improper Privilege Management in octoprint/octoprint","id":"CVE-2022-3068","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"privilege_escalation","year":"2022"},"n_packages":3,"n_references":2,"next":{"headline":"Wordlift \u003c 3.37.2 - Admin+ Stored Cross-Site Scripting","id":"CVE-2022-3069"},"packages":[{"ecosystem":"PyPI","fixed":["1.8.3"],"introduced":["0"],"last_affected":[],"package":"OctoPrint","purl":null,"source":"GHSA-2p75-q37p-f852"},{"ecosystem":"PyPI","fixed":["1.8.3"],"introduced":["0"],"last_affected":[],"package":"octoprint","purl":"pkg:pypi/octoprint","source":"GHSA-2p75-q37p-f852"},{"ecosystem":"PyPI","fixed":["1.8.3"],"introduced":["0"],"last_affected":[],"package":"octoprint","purl":"pkg:pypi/octoprint","source":"PYSEC-2022-283"}],"prev":{"headline":"Missing authorization in GitLab","id":"CVE-2022-3067"},"products":["octoprint/octoprint"],"published":"2022-09-21","related":[{"cvss_score":9.1,"headline":"Information disclosure in n/a","id":"CVE-2018-16710","kev_date_added":null,"published":"2018-09-07"},{"cvss_score":7.5,"headline":"OctoPrint is Vulnerable to RCE Attacks via Unsanitized Filename in File Upload","id":"CVE-2025-58180","kev_date_added":null,"published":"2025-09-09"},{"cvss_score":7.5,"headline":"Cross-site Scripting (XSS) - DOM in octoprint/octoprint","id":"CVE-2022-1430","kev_date_added":null,"published":"2022-05-18"},{"cvss_score":7.5,"headline":"Cross-site Scripting (XSS) - Generic in octoprint/octoprint","id":"CVE-2022-1432","kev_date_added":null,"published":"2022-05-18"},{"cvss_score":7.1,"headline":"OctoPrint Authentication Bypass via X-Forwarded-For Header when autologinLocal is enabled","id":"CVE-2024-32977","kev_date_added":null,"published":"2024-05-14"},{"cvss_score":6.5,"headline":"OctoPrint Vulnerable to Denial of Service through malformed HTTP request","id":"CVE-2025-48879","kev_date_added":null,"published":"2025-06-10"},{"cvss_score":6.5,"headline":"OctoPrint Incorrect Access Control","id":"CVE-2021-32560","kev_date_added":null,"published":"2021-05-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-28","vendors":["octoprint"]},"summary":"Attackers can exploit improper privilege management in OctoPrint to escalate privileges, requiring an upgrade to the latest version.","url":"https://insights.sbomify.com/CVE-2022-3068/"}