# CVE-2022-30705: WordPress WordPress Ping Optimizer Plugin <= 2.35.1.2.3 is vulnerable to Cross Site Request Forgery (CSRF)

> Attackers can trick authenticated users into performing unwanted actions in the WordPress Ping Optimizer plugin.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 27 Mar 2023
- **Updated:** 28 Apr 2026
- **Also known as:** GHSA-x2m8-4x5h-2r66

## What is CVE-2022-30705?

CVE-2022-30705 is a medium-severity vulnerability in Pankaj Jha WordPress Ping Optimizer, published on 27 Mar 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-Site Request Forgery (CSRF) vulnerability in Pankaj Jha WordPress Ping Optimizer plugin <= 2.35.1.2.3 versions.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2022-30705?

It affects 1 product.


Products: Wordpress Ping Optimizer Project Wordpress Ping Optimizer.

## How do I fix CVE-2022-30705?

No fix has been published for CVE-2022-30705 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-30705 being exploited?

There is no known exploitation of CVE-2022-30705 in the wild and no public exploit code.

## Other vulnerabilities in Pankaj Jha WordPress Ping Optimizer

- [CVE-2023-6385](https://insights.sbomify.com/CVE-2023-6385/): WordPress Ping Optimizer <= 2.35.1.3.0 - Log Clearing via CSRF (medium 4.3)
- [CVE-2022-1591](https://insights.sbomify.com/CVE-2022-1591/): WordPress Ping Optimizer < 2.35.1.3.0 - Arbitrary Settings Update via CSRF (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-30705 and fix it if it is affected.

What it is: CVE-2022-30705 is a medium-severity vulnerability in Pankaj Jha WordPress Ping Optimizer, published on 27 Mar 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-30705 in the wild and no public exploit code.

Affected product: Pankaj Jha WordPress Ping Optimizer. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-30705/ (Markdown: https://insights.sbomify.com/CVE-2022-30705/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-30705
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-30705
- OSV: https://osv.dev/vulnerability/CVE-2022-30705

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-30705/
Summaries are generated and may contain mistakes; the official description above is the record.
