# CVE-2022-30781: Shell command injection in gitea

> Attackers can execute arbitrary commands via unescaped git fetch remote inputs in Gitea, requiring an upgrade to secure the platform.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 May 2022
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-gitea-2022-30781, CLEANSTART-2025-TF34768, GHSA-p5f9-c9j9-g8qx, GO-2022-0450

## What is CVE-2022-30781?

CVE-2022-30781 is a high-severity command injection vulnerability in Gitea Gitea, published on 16 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Gitea before 1.16.7 does not escape git fetch remote.

Weakness: CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2022-30781?

4 open source packages ship an affected version, including code.gitea.io/gitea and gitea. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `code.gitea.io/gitea` | Go | All versions | 1.16.7 |
| `code.gitea.io/gitea` | Go | All versions | 1.16.7 |
| `code.gitea.io/gitea` | Go | All versions | 1.16.7 |
| `gitea` | Bitnami | All versions | 1.16.7 |

Products: Gitea Gitea.

## How do I fix CVE-2022-30781?

Upgrade code.gitea.io/gitea to 1.16.7 or later.

## Is CVE-2022-30781 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-30781 exists.

Public exploit code:

- 🍵 Gitea repository migration remote command execution exploit. (github_poc): https://github.com/wuhan005/CVE-2022-30781
- CVE-2022-30781 (github_poc): https://github.com/403ArkhamS3c/cve-gitea
- Gitea Git Fetch Remote Code Execution (metasploit)
- Gitea 1.16.6 - Remote Code Execution (RCE) (Metasploit) (exploitdb)

## Other vulnerabilities in Gitea Gitea

- [CVE-2026-60004](https://insights.sbomify.com/CVE-2026-60004/): Gitea Code Injection (critical 9.8, exploited in the wild)
- [CVE-2026-73278](https://insights.sbomify.com/CVE-2026-73278/): Gitea WebAuthn bypass during OAuth and OIDC sign-in (critical 9.8)
- [CVE-2026-94205](https://insights.sbomify.com/CVE-2026-94205/): Gitea fork workflow approval bypass through maintainer-triggered events (critical 9.8)
- [CVE-2022-42968](https://insights.sbomify.com/CVE-2022-42968/): Gitea vulnerable to Argument Injection (critical 9.8)
- [CVE-2021-45330](https://insights.sbomify.com/CVE-2021-45330/): Improper Privilege Management in Gitea (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-30781 and fix it if it is affected.

What it is: CVE-2022-30781 is a high-severity command injection vulnerability in Gitea Gitea, published on 16 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-30781 exists.

Affected packages and fixed versions:
- code.gitea.io/gitea (Go): affected all versions; fixed in 1.16.7
- code.gitea.io/gitea (Go): affected all versions; fixed in 1.16.7
- code.gitea.io/gitea (Go): affected all versions; fixed in 1.16.7
- gitea (Bitnami): affected all versions; fixed in 1.16.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-30781/ (Markdown: https://insights.sbomify.com/CVE-2022-30781/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-30781
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-30781
- OSV: https://osv.dev/vulnerability/CVE-2022-30781

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-30781/
Summaries are generated and may contain mistakes; the official description above is the record.
