# CVE-2022-30947: Path traversal in Jenkins Git Mercurial and Repo Plugins

> Attackers with pipeline configuration access can use local paths to read SCM contents from other projects on the Jenkins controller.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 May 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-84cm-vjwm-m979

## What is CVE-2022-30947?

CVE-2022-30947 is a high-severity path traversal vulnerability in Jenkins Git Plugin, published on 17 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Jenkins Git Plugin 4.11.1 and earlier allows attackers able to configure pipelines to check out some SCM repositories stored on the Jenkins controller's file system using local paths as SCM URLs, obtaining limited information about other projects' SCM contents.

## Which versions are affected by CVE-2022-30947?

6 open source packages ship an affected version, including org.jenkins-ci.plugins:git, org.jenkins-ci.plugins:mercurial and org.jenkins-ci.plugins:repo. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:git` | Maven | All versions | 4.11.2 |
| `org.jenkins-ci.plugins:git` | Maven | All versions | 4.11.2 |
| `org.jenkins-ci.plugins:mercurial` | Maven | All versions | 2.16.1 |
| `org.jenkins-ci.plugins:mercurial` | Maven | All versions | 2.16.1 |
| `org.jenkins-ci.plugins:repo` | Maven | All versions | 1.15.0 |
| `org.jenkins-ci.plugins:repo` | Maven | All versions | 1.15.0 |

Products: Jenkins Git.

## How do I fix CVE-2022-30947?

Upgrade org.jenkins-ci.plugins:git to 4.11.2 or later.

## Is CVE-2022-30947 being exploited?

There is no known exploitation of CVE-2022-30947 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Git Plugin

- [CVE-2022-36882](https://insights.sbomify.com/CVE-2022-36882/): Lack of authentication mechanism in Jenkins Git Plugin webhook (high 8.8)
- [CVE-2022-36883](https://insights.sbomify.com/CVE-2022-36883/): Lack of authentication mechanism in Jenkins Git Plugin webhook (high 7.5)
- [CVE-2017-1000092](https://insights.sbomify.com/CVE-2017-1000092/): Cross-Site Request Forgery in Jenkins Git Plugin (high 7.5)
- [CVE-2022-38663](https://insights.sbomify.com/CVE-2022-38663/): Improper masking of credentials Jenkins in Git Plugin (medium 6.5)
- [CVE-2018-1000182](https://insights.sbomify.com/CVE-2018-1000182/): Server-Side Request Forgery in Jenkins Git Plugin (medium 6.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-30947 and fix it if it is affected.

What it is: CVE-2022-30947 is a high-severity path traversal vulnerability in Jenkins Git Plugin, published on 17 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-30947 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:git (Maven): affected all versions; fixed in 4.11.2
- org.jenkins-ci.plugins:git (Maven): affected all versions; fixed in 4.11.2
- org.jenkins-ci.plugins:mercurial (Maven): affected all versions; fixed in 2.16.1
- org.jenkins-ci.plugins:mercurial (Maven): affected all versions; fixed in 2.16.1
- org.jenkins-ci.plugins:repo (Maven): affected all versions; fixed in 1.15.0
- org.jenkins-ci.plugins:repo (Maven): affected all versions; fixed in 1.15.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-30947/ (Markdown: https://insights.sbomify.com/CVE-2022-30947/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-30947
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-30947
- OSV: https://osv.dev/vulnerability/CVE-2022-30947

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-30947/
Summaries are generated and may contain mistakes; the official description above is the record.
