# CVE-2022-30951: Missing Authorization in Jenkins WMI Windows Agents plugin

> Attackers can start processes on Windows agents without login permissions due to missing access control in the Jenkins WMI Windows Agents Plugin.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 May 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-p566-wpxx-574m

## What is CVE-2022-30951?

CVE-2022-30951 is a high-severity missing authorization vulnerability in Jenkins WMI Windows Agents Plugin, published on 17 May 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins WMI Windows Agents Plugin 1.8 and earlier includes the Windows Remote Command library does not implement access control, potentially allowing users to start processes even if they're not allowed to log in.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2022-30951?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:windows-slaves. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:windows-slaves` | Maven | All versions | 1.8.1 |
| `org.jenkins-ci.plugins:windows-slaves` | Maven | All versions | 1.8.1 |

Products: Jenkins Wmi Windows Agents.

## How do I fix CVE-2022-30951?

Upgrade org.jenkins-ci.plugins:windows-slaves to 1.8.1 or later.

## Is CVE-2022-30951 being exploited?

There is no known exploitation of CVE-2022-30951 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins WMI Windows Agents Plugin

- [CVE-2022-30950](https://insights.sbomify.com/CVE-2022-30950/): Buffer overflow in Jenkins WMI Windows Agents plugin (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-30951 and fix it if it is affected.

What it is: CVE-2022-30951 is a high-severity missing authorization vulnerability in Jenkins WMI Windows Agents Plugin, published on 17 May 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-30951 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:windows-slaves (Maven): affected all versions; fixed in 1.8.1
- org.jenkins-ci.plugins:windows-slaves (Maven): affected all versions; fixed in 1.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-30951/ (Markdown: https://insights.sbomify.com/CVE-2022-30951/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-30951
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-30951
- OSV: https://osv.dev/vulnerability/CVE-2022-30951

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-30951/
Summaries are generated and may contain mistakes; the official description above is the record.
