# CVE-2022-30954: Missing permission check in Jenkins Blue Ocean Plugin

> Attackers with read permissions can bypass authorization checks to connect to arbitrary HTTP servers via vulnerable endpoints.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 May 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-5m4q-x28v-q6wp

## What is CVE-2022-30954?

CVE-2022-30954 is a medium-severity missing authorization vulnerability in Jenkins Blue Ocean Plugin, published on 17 May 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins Blue Ocean Plugin 1.25.3 and earlier does not perform a permission check in several HTTP endpoints, allowing attackers with Overall/Read permission to connect to an attacker-specified HTTP server.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2022-30954?

2 open source packages ship an affected version, including io.jenkins.blueocean:blueocean-parent. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.jenkins.blueocean:blueocean-parent` | Maven | All versions | 1.25.4 |
| `io.jenkins.blueocean:blueocean-parent` | Maven | All versions | 1.25.4 |

Products: Jenkins Blue Ocean.

## How do I fix CVE-2022-30954?

Upgrade io.jenkins.blueocean:blueocean-parent to 1.25.4 or later.

## Is CVE-2022-30954 being exploited?

There is no known exploitation of CVE-2022-30954 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Blue Ocean Plugin

- [CVE-2023-40341](https://insights.sbomify.com/CVE-2023-40341/): Jenkins Blue Ocean Plugin cross-site request forgery vulnerability (high 8.8)
- [CVE-2017-1000106](https://insights.sbomify.com/CVE-2017-1000106/): Improper Authentication in Jenkins Blue Ocean Plugin (high 8.5)
- [CVE-2022-30952](https://insights.sbomify.com/CVE-2022-30952/): Insufficiently Protected Credentials in Jenkins Pipeline SCM API for Blue Ocean Plugin (medium 6.5)
- [CVE-2022-30953](https://insights.sbomify.com/CVE-2022-30953/): Cross Site Request Forgery in Jenkins Blue Ocean Plugin (medium 6.5)
- [CVE-2020-2254](https://insights.sbomify.com/CVE-2020-2254/): Path traversal vulnerability in Blue Ocean Plugin (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-30954 and fix it if it is affected.

What it is: CVE-2022-30954 is a medium-severity missing authorization vulnerability in Jenkins Blue Ocean Plugin, published on 17 May 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-30954 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.jenkins.blueocean:blueocean-parent (Maven): affected all versions; fixed in 1.25.4
- io.jenkins.blueocean:blueocean-parent (Maven): affected all versions; fixed in 1.25.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-30954/ (Markdown: https://insights.sbomify.com/CVE-2022-30954/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-30954
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-30954
- OSV: https://osv.dev/vulnerability/CVE-2022-30954

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-30954/
Summaries are generated and may contain mistakes; the official description above is the record.
