# CVE-2022-30956: Cross-site Scripting in Jenkins Rundeck Plugin

> Attackers can inject malicious scripts via crafted Rundeck webhook payloads, potentially compromising user sessions or executing code in Jenkins.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 May 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-4m42-8qfq-h3q9

## What is CVE-2022-30956?

CVE-2022-30956 is a medium-severity cross-site scripting vulnerability in Jenkins Rundeck Plugin, published on 17 May 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Jenkins Rundeck Plugin 3.6.10 and earlier does not restrict URL schemes in Rundeck webhook submissions, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to submit crafted Rundeck webhook payloads.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-30956?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:rundeck. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:rundeck` | Maven | All versions | 3.6.11 |
| `org.jenkins-ci.plugins:rundeck` | Maven | All versions | 3.6.11 |

Products: Jenkins Rundeck.

## How do I fix CVE-2022-30956?

Upgrade org.jenkins-ci.plugins:rundeck to 3.6.11 or later.

## Is CVE-2022-30956 being exploited?

There is no known exploitation of CVE-2022-30956 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Rundeck Plugin

- [CVE-2022-41234](https://insights.sbomify.com/CVE-2022-41234/): Missing webhook endpoint authorization in Jenkins Rundeck Plugin (high 8.8)
- [CVE-2020-2144](https://insights.sbomify.com/CVE-2020-2144/): XXE vulnerability in Rundeck Plugin (high 7.1)
- [CVE-2019-16556](https://insights.sbomify.com/CVE-2019-16556/): Jenkins Rundeck Plugin stored credentials in plain text (medium 6.5)
- [CVE-2022-41233](https://insights.sbomify.com/CVE-2022-41233/): Jenkins Rundeck Plugin Missing Authorization vulnerability (medium 4.3)
- [CVE-2019-10454](https://insights.sbomify.com/CVE-2019-10454/): Jenkins Rundeck Plugin CSRF vulnerability (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-30956 and fix it if it is affected.

What it is: CVE-2022-30956 is a medium-severity cross-site scripting vulnerability in Jenkins Rundeck Plugin, published on 17 May 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-30956 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:rundeck (Maven): affected all versions; fixed in 3.6.11
- org.jenkins-ci.plugins:rundeck (Maven): affected all versions; fixed in 3.6.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-30956/ (Markdown: https://insights.sbomify.com/CVE-2022-30956/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-30956
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-30956
- OSV: https://osv.dev/vulnerability/CVE-2022-30956

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-30956/
Summaries are generated and may contain mistakes; the official description above is the record.
