{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:app-detector. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-30960 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:app-detector to 1.0.9 or later.","what":"CVE-2022-30960 is a medium-severity cross-site scripting vulnerability in Jenkins Application Detector Plugin, published on 17 May 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-30960 and fix it if it is affected.\n\nWhat it is: CVE-2022-30960 is a medium-severity cross-site scripting vulnerability in Jenkins Application Detector Plugin, published on 17 May 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-30960 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:app-detector (Maven): affected all versions; fixed in 1.0.9\n- org.jenkins-ci.plugins:app-detector (Maven): affected all versions; fixed in 1.0.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-30960/ (Markdown: https://insights.sbomify.com/CVE-2022-30960/index.md)","id":"CVE-2022-30960","markdown":"https://insights.sbomify.com/CVE-2022-30960/index.md","name":"CVE-2022-30960","record":{"aliases":["GHSA-6wh8-mr6f-6cx2"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins plugin","requires_auth":"low_privilege","summary":"Stored XSS in Jenkins Application Detector Plugin allows attackers with configure permissions to execute scripts in victim browsers.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"application_detector","vendor":"jenkins"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Jenkins Application Detector Plugin 1.0.8 and earlier does not escape the name of Chois Application Version parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting in Jenkins Application Detector Plugin","id":"CVE-2022-30960","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":1,"next":{"headline":"Cross-site Scripting in Jenkins Autocomplete Parameter Plugin","id":"CVE-2022-30961"},"packages":[{"ecosystem":"Maven","fixed":["1.0.9"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:app-detector","purl":null,"source":"GHSA-6wh8-mr6f-6cx2"},{"ecosystem":"Maven","fixed":["1.0.9"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:app-detector","purl":"pkg:maven/org.jenkins-ci.plugins/app-detector","source":"GHSA-6wh8-mr6f-6cx2"}],"prev":{"headline":"Missing Authorization in Jenkins SSH plugin","id":"CVE-2022-30959"},"products":["Jenkins Application Detector Plugin"],"published":"2022-05-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Jenkins project"]},"summary":"Stored XSS in Jenkins Application Detector Plugin allows attackers with configure permissions to execute scripts in victim browsers.","url":"https://insights.sbomify.com/CVE-2022-30960/"}