{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.tika:tika-core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-30973 in the wild and no public exploit code.","fix":"Upgrade org.apache.tika:tika-core to 1.28.3 or later.","what":"CVE-2022-30973 is a medium-severity denial of service vulnerability in Apache Tika, published on 31 May 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-30973 and fix it if it is affected.\n\nWhat it is: CVE-2022-30973 is a medium-severity denial of service vulnerability in Apache Tika, published on 31 May 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-30973 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.tika:tika-core (Maven): affected from 1.17; fixed in 1.28.3\n- org.apache.tika:tika-core (Maven): affected from 1.17; fixed in 1.28.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-30973/ (Markdown: https://insights.sbomify.com/CVE-2022-30973/index.md)","id":"CVE-2022-30973","markdown":"https://insights.sbomify.com/CVE-2022-30973/index.md","name":"CVE-2022-30973","record":{"aliases":["GHSA-qw3f-w4pf-jh5f","UBUNTU-CVE-2022-30973"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Apache Tika library","requires_auth":"none","summary":"A regular expression backtracking flaw in Apache Tika's StandardsExtractingContentHandler allows attackers to cause denial of service via crafted files.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"tika","vendor":"apache"}],"cvss":{"score":5.5,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[],"description":"We failed to apply the fix for CVE-2022-30126 to the 1.x branch in the 1.28.2 release. In Apache Tika, a regular expression in the StandardsText class, used by the StandardsExtractingContentHandler could lead to a denial of service caused by backtracking on a specially crafted file. This only affects users who are running the StandardsExtractingContentHandler, which is a non-standard handler. This is fixed in 1.28.3.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Missing fix for CVE-2022-30126 in 1.28.2","id":"CVE-2022-30973","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":2,"n_references":4,"next":{"headline":"Denial of service in n/a","id":"CVE-2022-30974"},"packages":[{"ecosystem":"Maven","fixed":["1.28.3"],"introduced":["1.17"],"last_affected":[],"package":"org.apache.tika:tika-core","purl":null,"source":"GHSA-qw3f-w4pf-jh5f"},{"ecosystem":"Maven","fixed":["1.28.3"],"introduced":["1.17"],"last_affected":[],"package":"org.apache.tika:tika-core","purl":"pkg:maven/org.apache.tika/tika-core","source":"GHSA-qw3f-w4pf-jh5f"}],"prev":{"headline":"Cross Site Request Forgery in Jenkins Storable Configs Plugin","id":"CVE-2022-30972"},"products":["Apache Tika"],"published":"2022-05-31","related":[{"cvss_score":8.8,"headline":"Allocation of Resources Without Limits or Throttling in Apache Tika","id":"CVE-2019-10088","kev_date_added":null,"published":"2019-08-02"},{"cvss_score":8.4,"headline":"Apache Tika has XXE vulnerability","id":"CVE-2025-66516","kev_date_added":null,"published":"2025-12-04"},{"cvss_score":8.4,"headline":"Apache Tika PDF parser module: XXE vulnerability in PDFParser's handling of XFA","id":"CVE-2025-54988","kev_date_added":null,"published":"2025-08-20"},{"cvss_score":8.1,"headline":"Command injection in org.apache.tika:tika-core","id":"CVE-2018-1335","kev_date_added":null,"published":"2018-04-25"},{"cvss_score":7.8,"headline":"Allocation of Resources Without Limits or Throttling in Apache Tika","id":"CVE-2019-10094","kev_date_added":null,"published":"2019-08-02"},{"cvss_score":7.8,"headline":"Apache Tika does not properly initialize the XML parser or choose handlers","id":"CVE-2016-4434","kev_date_added":null,"published":"2017-09-29"},{"cvss_score":7.5,"headline":"Apache Tika is vulnerable to entity expansions which can lead to a denial of service attack","id":"CVE-2018-11796","kev_date_added":null,"published":"2018-10-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Apache Software Foundation"]},"summary":"A regular expression backtracking flaw in Apache Tika's StandardsExtractingContentHandler allows attackers to cause denial of service via crafted files.","url":"https://insights.sbomify.com/CVE-2022-30973/"}