CVE-2022-31000 CSRF allows attacker to finalize/unfinalize order adjustments in solidus_backend
Attackers can trick administrators into modifying order adjustments via CSRF, requiring an upgrade to the Solidus backend.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-31000?
CVE-2022-31000 is a low-severity vulnerability in solidusio solidus, published on 1 Jun 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
solidus_backend is the admin interface for the Solidus e-commerce framework. Versions prior to 3.1.6, 3.0.6, and 2.11.16 contain a cross-site request forgery (CSRF) vulnerability. The vulnerability allows attackers to change the state of an order's adjustments if they hold its number, and the execution happens on a store administrator's computer. Users should upgrade to solidus_backend 3.1.6, 3.0.6, or 2.11.16 to receive a patch.
Weakness: CWE-352
Which versions are affected by CVE-2022-31000?
6 open source packages ship an affected version, including solidus_backend. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
solidus_backend RubyGems | All versions | 2.11.16 |
solidus_backend RubyGems | All versions | 2.11.16 |
solidus_backend RubyGems | From 3.0.0 | 3.0.6 |
solidus_backend RubyGems | From 3.0.0 | 3.0.6 |
solidus_backend RubyGems | From 3.1.0 | 3.1.6 |
solidus_backend RubyGems | From 3.1.0 | 3.1.6 |
Products include Nebulab Solidus.
How do I fix CVE-2022-31000?
Upgrade solidus_backend to a fixed version for your release line: 2.11.16, 3.0.6 or 3.1.6.
Is CVE-2022-31000 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31000 exists.
Other vulnerabilities in solidusio solidus
Sources
Also known as GHSA-8639-qx56-r428.