{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-31001 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2022-31001 is a high-severity memory corruption vulnerability in Debian Debian Linux, published on 31 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-31001 and fix it if it is affected.\n\nWhat it is: CVE-2022-31001 is a high-severity memory corruption vulnerability in Debian Debian Linux, published on 31 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-31001 in the wild and no public exploit code.\n\nAffected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-31001/ (Markdown: https://insights.sbomify.com/CVE-2022-31001/index.md)","id":"CVE-2022-31001","markdown":"https://insights.sbomify.com/CVE-2022-31001/index.md","name":"CVE-2022-31001","record":{"aliases":["ALPINE-CVE-2022-31001","DEBIAN-CVE-2022-31001","GHSA-79jq-hh82-cv9g","UBUNTU-CVE-2022-31001","openSUSE-SU-2026:10964-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"SIP User-Agent library","requires_auth":"none","summary":"An attacker can cause a crash in FreeSWITCH by sending a malicious SDP message to the Sofia-SIP library due to an out-of-bounds read.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"sofia-sip","vendor":"signalwire"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"Sofia-SIP is an open-source Session Initiation Protocol (SIP) User-Agent library. Prior to version 1.13.8, an attacker can send a message with evil sdp to FreeSWITCH, which may cause crash. This type of crash may be caused by `#define MATCH(s, m) (strncmp(s, m, n = sizeof(m) - 1) == 0)`, which will make `n` bigger and trigger out-of-bound access when `IS_NON_WS(s[n])`. Version 1.13.8 contains a patch for this issue.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Out-of-bounds Read in Sofia-SIP","id":"CVE-2022-31001","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"debian:debian_linux","products":["debian:debian_linux"],"type":"memory_corruption","year":"2022"},"n_packages":1,"n_references":5,"next":{"headline":"Out-of-bounds Read in Sofia-SIP","id":"CVE-2022-31002"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.13.17+50-1.1"],"introduced":["0"],"last_affected":[],"package":"sofia-sip","purl":"pkg:rpm/opensuse/sofia-sip\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10964-1"}],"prev":{"headline":"CSRF allows attacker to finalize/unfinalize order adjustments in solidus_backend","id":"CVE-2022-31000"},"products":["sofia-sip"],"published":"2022-05-31","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["freeswitch"]},"summary":"An attacker can cause a crash in FreeSWITCH by sending a malicious SDP message to the Sofia-SIP library due to an out-of-bounds read.","url":"https://insights.sbomify.com/CVE-2022-31001/"}