{"answers":{"affected":"3 open source packages ship an affected version, including indy-node. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-31006 in the wild and no public exploit code.","fix":"Upgrade indy-node to 1.13.0.dev2 or later.","what":"CVE-2022-31006 is a high-severity denial of service vulnerability in hyperledger indy-node, published on 9 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-31006 and fix it if it is affected.\n\nWhat it is: CVE-2022-31006 is a high-severity denial of service vulnerability in hyperledger indy-node, published on 9 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-31006 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- indy-node (PyPI): affected all versions up to 1.12.6; no fix listed\n- indy-node (PyPI): affected all versions up to 1.12.6; no fix listed\n- indy-node (PyPI): affected all versions; fixed in 1.13.0.dev2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-31006/ (Markdown: https://insights.sbomify.com/CVE-2022-31006/index.md)","id":"CVE-2022-31006","markdown":"https://insights.sbomify.com/CVE-2022-31006/index.md","name":"CVE-2022-31006","record":{"aliases":["GHSA-x996-7qh9-7ff7","PYSEC-2022-270"],"analysis":{"component_type":"server_software","fix_type":"configuration_change","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Hyperledger Indy node","requires_auth":"none","summary":"Attackers can exhaust client connections to Hyperledger Indy nodes, causing denial of service until firewall rules are tuned.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"indy-node","vendor":"linuxfoundation"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"indy-node is the server portion of Hyperledger Indy, a distributed ledger purpose-built for decentralized identity. In vulnerable versions of indy-node, an attacker can max out the number of client connections allowed by the ledger, leaving the ledger unable to be used for its intended purpose. However, the ledger content will not be impacted and the ledger will resume functioning after the attack. This attack exploits the trade-off between resilience and availability. Any protection against abusive client connections will also prevent the network being accessed by certain legitimate users. As a result, validator nodes must tune their firewall rules to ensure the right trade-off for their network's expected users. The guidance to network operators for the use of firewall rules in the deployment of Indy networks has been modified to better protect against denial of service attacks by increasing the cost and complexity in mounting such attacks. The mitigation for this vulnerability is not in the Hyperledger Indy code per se, but rather in the individual deployments of Indy. The mitigations should be applied to all deployments of Indy, and are not related to a particular release.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Hyperledger Indy DOS vulnerability","id":"CVE-2022-31006","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":3,"n_references":2,"next":{"headline":"Privilege escalation from administrator in eLabFTW","id":"CVE-2022-31007"},"packages":[{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["1.12.6"],"package":"indy-node","purl":null,"source":"GHSA-x996-7qh9-7ff7"},{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["1.12.6"],"package":"indy-node","purl":"pkg:pypi/indy-node","source":"GHSA-x996-7qh9-7ff7"},{"ecosystem":"PyPI","fixed":["1.13.0.dev2"],"introduced":["0"],"last_affected":[],"package":"indy-node","purl":"pkg:pypi/indy-node","source":"PYSEC-2022-270"}],"prev":{"headline":"Integer Overflow in Vapor's HTTP Range Request","id":"CVE-2022-31005"},"products":["indy-node"],"published":"2022-09-09","related":[{"cvss_score":8.8,"headline":"Remote code execution in Indy's NODE_UPGRADE transaction","id":"CVE-2022-31020","kev_date_added":null,"published":"2022-09-06"},{"cvss_score":7.5,"headline":"Authorization bypass in Hyperledger Indy","id":"CVE-2020-11093","kev_date_added":null,"published":"2020-12-24"},{"cvss_score":7.5,"headline":"Uncontrolled Resource Consumption in Indy Node","id":"CVE-2020-11090","kev_date_added":null,"published":"2020-06-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["hyperledger"]},"summary":"Attackers can exhaust client connections to Hyperledger Indy nodes, causing denial of service until firewall rules are tuned.","url":"https://insights.sbomify.com/CVE-2022-31006/"}