# CVE-2022-31006: Hyperledger Indy DOS vulnerability

> Attackers can exhaust client connections to Hyperledger Indy nodes, causing denial of service until firewall rules are tuned.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Sep 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-x996-7qh9-7ff7, PYSEC-2022-270

## What is CVE-2022-31006?

CVE-2022-31006 is a high-severity denial of service vulnerability in hyperledger indy-node, published on 9 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

indy-node is the server portion of Hyperledger Indy, a distributed ledger purpose-built for decentralized identity. In vulnerable versions of indy-node, an attacker can max out the number of client connections allowed by the ledger, leaving the ledger unable to be used for its intended purpose. However, the ledger content will not be impacted and the ledger will resume functioning after the attack. This attack exploits the trade-off between resilience and availability. Any protection against abusive client connections will also prevent the network being accessed by certain legitimate users. As a result, validator nodes must tune their firewall rules to ensure the right trade-off for their network's expected users. The guidance to network operators for the use of firewall rules in the deployment of Indy networks has been modified to better protect against denial of service attacks by increasing the cost and complexity in mounting such attacks. The mitigation for this vulnerability is not in the Hyperledger Indy code per se, but rather in the individual deployments of Indy. The mitigations should be applied to all deployments of Indy, and are not related to a particular release.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2022-31006?

3 open source packages ship an affected version, including indy-node. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `indy-node` | PyPI | All versions to 1.12.6 | None |
| `indy-node` | PyPI | All versions to 1.12.6 | None |
| `indy-node` | PyPI | All versions | 1.13.0.dev2 |

Products: Linuxfoundation Indy-Node.

## How do I fix CVE-2022-31006?

Upgrade indy-node to 1.13.0.dev2 or later.

## Is CVE-2022-31006 being exploited?

There is no known exploitation of CVE-2022-31006 in the wild and no public exploit code.

## Other vulnerabilities in hyperledger indy-node

- [CVE-2022-31020](https://insights.sbomify.com/CVE-2022-31020/): Remote code execution in Indy's NODE_UPGRADE transaction (high 8.8)
- [CVE-2020-11093](https://insights.sbomify.com/CVE-2020-11093/): Authorization bypass in Hyperledger Indy (high 7.5)
- [CVE-2020-11090](https://insights.sbomify.com/CVE-2020-11090/): Uncontrolled Resource Consumption in Indy Node (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31006 and fix it if it is affected.

What it is: CVE-2022-31006 is a high-severity denial of service vulnerability in hyperledger indy-node, published on 9 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-31006 in the wild and no public exploit code.

Affected packages and fixed versions:
- indy-node (PyPI): affected all versions up to 1.12.6; no fix listed
- indy-node (PyPI): affected all versions up to 1.12.6; no fix listed
- indy-node (PyPI): affected all versions; fixed in 1.13.0.dev2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31006/ (Markdown: https://insights.sbomify.com/CVE-2022-31006/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31006
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31006
- OSV: https://osv.dev/vulnerability/CVE-2022-31006

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31006/
Summaries are generated and may contain mistakes; the official description above is the record.
