# CVE-2022-31008: Predictable credential obfuscation seed value used in rabbitmq-server

> Attackers can decrypt sensitive URIs in logs due to predictable encryption seeds in RabbitMQ Shovel and Federation plugins.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2022
- **Updated:** 23 Apr 2025
- **Also known as:** BIT-rabbitmq-2022-31008, DEBIAN-CVE-2022-31008, GHSA-v9gv-xp36-jgj8, SUSE-SU-2022:4378-1, UBUNTU-CVE-2022-31008

## What is CVE-2022-31008?

CVE-2022-31008 is a medium-severity vulnerability in Broadcom Rabbitmq Server, published on 6 Oct 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

RabbitMQ is a multi-protocol messaging and streaming broker. In affected versions the shovel and federation plugins perform URI obfuscation in their worker (link) state. The encryption key used to encrypt the URI was seeded with a predictable secret. This means that in case of certain exceptions related to Shovel and Federation plugins, reasonably easily deobfuscatable data could appear in the node log. Patched versions correctly use a cluster-wide secret for that purpose. This issue has been addressed and Patched versions: `3.10.2`, `3.9.18`, `3.8.32` are available. Users unable to upgrade should disable the Shovel and Federation plugins.

Weakness: CWE-335 (Incorrect Usage of Seeds in Pseudo-Random Number Generator (PRNG)), CWE-330 (Use of Insufficiently Random Values)

## Which versions are affected by CVE-2022-31008?

7 open source packages ship an affected version, including rabbitmq and rabbit_common. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rabbitmq` | Bitnami | All versions | 3.8.32 |
| `rabbit_common` | Hex | From 3.10.0 | 3.10.2 |
| `rabbit_common` | Hex | From 3.10.0 | 3.10.2 |
| `rabbit_common` | Hex | From 3.8.0 | 3.8.32 |
| `rabbit_common` | Hex | From 3.8.0 | 3.8.32 |
| `rabbit_common` | Hex | From 3.9.0 | 3.9.18 |
| `rabbit_common` | Hex | From 3.9.0 | 3.9.18 |
| `rabbitmq-server` | SUSE:Linux Enterprise Module for Server Applications 15 SP3 | All versions | 3.8.11-150300.3.11.1 |
| `rabbitmq-server` | SUSE:Linux Enterprise Module for Server Applications 15 SP4 | All versions | 3.8.11-150300.3.11.1 |
| `rabbitmq-server` | openSUSE:Leap 15.3 | All versions | 3.8.11-150300.3.11.1 |
| `rabbitmq-server` | openSUSE:Leap 15.4 | All versions | 3.8.11-150300.3.11.1 |

Products: Broadcom Rabbitmq Server, Vmware Rabbitmq.

## How do I fix CVE-2022-31008?

Upgrade rabbitmq to 3.8.32 or later.

## Is CVE-2022-31008 being exploited?

There is no known exploitation of CVE-2022-31008 in the wild and no public exploit code.

## Other vulnerabilities in Broadcom Rabbitmq Server

- [CVE-2016-9877](https://insights.sbomify.com/CVE-2016-9877/): Auth bypass in Pivotal RabbitMQ 3.x before 3.5.8 and 3.6.x before 3.6.6; RabbitMQ for PCF 1.5.x before 1.5.20, 1.6.x before 1.6.12 and 1.7.x before 1.7.7 (critical 9.8)
- [CVE-2026-67404](https://insights.sbomify.com/CVE-2026-67404/): RabbitMQ: OAuth2 silent verify_none fallback for JWKS fetch (critical 9.2)
- [CVE-2026-67231](https://insights.sbomify.com/CVE-2026-67231/): RabbitMQ: Trust-store whitelist by Issuer+Serial only (critical 9.1)
- [CVE-2026-57219](https://insights.sbomify.com/CVE-2026-57219/): Information disclosure in rabbitmq-server (high 8.7)
- [CVE-2026-67236](https://insights.sbomify.com/CVE-2026-67236/): RabbitMQ: Plaintext username:password stored in an insecure cookie after successful POST /login (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31008 and fix it if it is affected.

What it is: CVE-2022-31008 is a medium-severity vulnerability in Broadcom Rabbitmq Server, published on 6 Oct 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-31008 in the wild and no public exploit code.

Affected packages and fixed versions:
- rabbitmq (Bitnami): affected all versions; fixed in 3.8.32
- rabbit_common (Hex): affected from 3.10.0; fixed in 3.10.2
- rabbit_common (Hex): affected from 3.10.0; fixed in 3.10.2
- rabbit_common (Hex): affected from 3.8.0; fixed in 3.8.32
- rabbit_common (Hex): affected from 3.8.0; fixed in 3.8.32
- rabbit_common (Hex): affected from 3.9.0; fixed in 3.9.18
- rabbit_common (Hex): affected from 3.9.0; fixed in 3.9.18

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31008/ (Markdown: https://insights.sbomify.com/CVE-2022-31008/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31008
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31008
- OSV: https://osv.dev/vulnerability/CVE-2022-31008

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31008/
Summaries are generated and may contain mistakes; the official description above is the record.
